Subject: [sup-devel] [PATCH] Added slip_rows config option

From: Daniel Schoepe <[email-masked]>
Date: Sun, 14 Mar 2010 17:07:05 +0100

This patch adds a slip_rows config option used by thread-view-mode
that passes the argument to scroll-mode, which already has that
functionality, but it was only used by completion-mode before.
The option controls how many lines of context are shown when scrolling
up/down.
---
 lib/sup.rb                        |    3 ++-
 lib/sup/modes/thread-view-mode.rb |    2 +-
 2 files changed, 3 insertions(+), 2 deletions(-)

diff --git a/lib/sup.rb b/lib/sup.rb
index 2765faa..c94c2b0 100644
--- a/lib/sup.rb
+++ b/lib/sup.rb
@@ -264,7 +264,8 @@ else
     :default_attachment_save_dir => "",
     :sent_source => "sup://sent",
     :poll_interval => 300,
-    :wrap_width => 0
+    :wrap_width => 0,
+    :slip_rows => 0
   }
   begin
     FileUtils.mkdir_p Redwood::BASE_DIR
diff --git a/lib/sup/modes/thread-view-mode.rb b/lib/sup/modes/thread-view-mode.rb
index 63fe211..6138dc7 100644
--- a/lib/sup/modes/thread-view-mode.rb
+++ b/lib/sup/modes/thread-view-mode.rb
@@ -111,7 +111,7 @@ EOS
   ## objects. @person_lines is a map from row #s to Person objects.
 
   def initialize thread, hidden_labels=[], index_mode=nil
-    super()
+    super :slip_rows => $config[:slip_rows]
     @thread = thread
     @hidden_labels = hidden_labels
 
-- 
1.7.0

_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Mon, 15 Mar 2010 01:12:52 -0400

Applied to master.