Subject: [sup-devel] [PATCH] force binary encoding before parsing decrypted messages

From: Rich Lane <[email-masked]>
Date: Sat, 2 Jan 2010 08:42:15 -0800

---
 lib/sup/crypto.rb |    2 ++
 1 files changed, 2 insertions(+), 0 deletions(-)

diff --git a/lib/sup/crypto.rb b/lib/sup/crypto.rb
index fb2661a..91652c7 100644
--- a/lib/sup/crypto.rb
+++ b/lib/sup/crypto.rb
@@ -130,6 +130,7 @@ class CryptoManager
     end
 
     output = IO.read output_fn.path
+    output.force_encoding Encoding::ASCII_8BIT if output.respond_to? :force_encoding
 
     ## there's probably a better way to do this, but we're using the output to
     ## look for a valid signature being present.
@@ -157,6 +158,7 @@ class CryptoManager
     msg = RMail::Parser.read output
     if msg.header.content_type =~ %r{^multipart/} && !msg.multipart?
       output = "MIME-Version: 1.0\n" + output
+      output.force_encoding Encoding::ASCII_8BIT if output.respond_to? :force_encoding
       msg = RMail::Parser.read output
     end
     notice = Chunk::CryptoNotice.new :valid, "This message has been decrypted for display"
-- 
1.6.3.3

_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Sun, 03 Jan 2010 07:16:03 -0800

Applied to the ruby-1.9-encoding branch, remerged into next. Thanks!
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel