Subject: Re: [sup-devel] [PATCH] added colorized dates in thread-index-mode

From: William Morgan <[email-masked]>
Date: Thu, 31 Dec 2009 11:49:03 -0800

Applied directly to master, thanks!
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Eric Sherman <[email-masked]>
Date: Thu, 31 Dec 2009 11:44:17 -0500

---
 lib/sup/colormap.rb                |    1 +
 lib/sup/modes/thread-index-mode.rb |    2 +-
 2 files changed, 2 insertions(+), 1 deletions(-)

diff --git a/lib/sup/colormap.rb b/lib/sup/colormap.rb
index fbbbfc9..c4a4024 100644
--- a/lib/sup/colormap.rb
+++ b/lib/sup/colormap.rb
@@ -50,6 +50,7 @@ class Colormap
     :system_buf => { :fg => "blue", :bg => "default" },
     :regular_buf => { :fg => "white", :bg => "default" },
     :modified_buffer => { :fg => "yellow", :bg => "default", :attrs => ["bold"] },
+    :date => { :fg => "white", :bg => "default"},
   }
   
   def initialize
diff --git a/lib/sup/modes/thread-index-mode.rb b/lib/sup/modes/thread-index-mode.rb
index 12a76f9..b3172e4 100644
--- a/lib/sup/modes/thread-index-mode.rb
+++ b/lib/sup/modes/thread-index-mode.rb
@@ -849,7 +849,7 @@ protected
 
     [ 
       [:tagged_color, @tags.tagged?(t) ? ">" : " "],
-      [:none, sprintf("%#{@date_width}s", date)],
+      [:date_color, sprintf("%#{@date_width}s", date)],
       (starred ? [:starred_color, "*"] : [:none, " "]),
     ] +
       from +
-- 
1.6.5.7
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel