Subject: [sup-devel] GPGME fixes

From: Gaudenz Steinlin <[email-masked]>
Date: Thu, 17 Feb 2011 15:49:01 +0100

Hi

While reimporting all my messages I encountered a few problemes with
the GPGME code. Please consider the attached fixes.

The second patch depends on the first (error message unification). But
if you don't like the first I can easily produce a standalone version.

Gaudenz

-- 
Ever tried. Ever failed. No matter.
Try again. Fail again. Fail better.
~ Samuel Beckett ~
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Gaudenz Steinlin <[email-masked]>
Date: Thu, 17 Feb 2011 21:44:08 +0100

Excerpts from Hamish D's message of 2011-02-17 19:45:20 +0100:
> 0001-Encode-multipart-messages-for-crypt-operations.patch already
> appears to be in master ...

Yes this one belongs to another patch serie already submitted earlier.
Sorry.

> 
> I like the others though, though in applying them I ran into some
> trouble, partly through my adding lines near the top of the file that
> change line numbers and seemed to confuse git. So they are now applied
> to a local copy, but in my name (but with your commit messages).
> 
> I imagine you would like them to be in your name, so I have not pushed
> them yet. If anyone could tell me how I should be applying them
> properly then I will do. And maybe it might be necessary to format the
> patches with options that give more context.
> 
> I'm hoping someone with more git knowledge than me can help ...

What command do you use to apply the patches? If I can fetch your
changes somewhere I can also rebase my patches on top of them.

Gaudenz

---

From: Hamish D <[email-masked]>
Date: Thu, 17 Feb 2011 22:57:42 +0000

> changes somewhere I can also rebase my patches on top of them.

My changes are on the gpgme branch on gitorious. I used the git apply
command. I also tried git am but that did't work at all.

Hamish

---

From: Hamish D <[email-masked]>
Date: Thu, 17 Feb 2011 18:45:20 +0000

Hamish