Subject: Re: [sup-devel] [PATCH] enable ruby-prof with SUP_PROFILE environment variable

From: Rich Lane <[email-masked]>
Date: Sat, 27 Feb 2010 02:45:04 -0500

Applied to master.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Sat, 23 Jan 2010 19:16:00 -0800

If SUP_PROFILE is set, it's used as the filename to dump profiling output
which you can use kcachegrind to inspect.
---
 bin/sup |   10 ++++++++++
 1 files changed, 10 insertions(+), 0 deletions(-)

diff --git a/bin/sup b/bin/sup
index 7824aca..f7c4af7 100755
--- a/bin/sup
+++ b/bin/sup
@@ -14,6 +14,11 @@ require 'fileutils'
 require 'trollop'
 require "sup"; Redwood::check_library_version_against "git"
 
+if ENV['SUP_PROFILE']
+  require 'ruby-prof'
+  RubyProf.start
+end
+
 if no_ncursesw
   debug "No 'ncursesw' gem detected. Install it for wide character support."
 end
@@ -379,6 +384,11 @@ ensure
   end
 
   Index.unlock
+
+  if (fn = ENV['SUP_PROFILE'])
+    result = RubyProf.stop
+    File.open(fn, 'w') { |io| RubyProf::CallTreePrinter.new(result).print(io) }
+  end
 end
 
 unless Redwood::exceptions.empty?
-- 
1.6.3.3

---

From: Anthony Martinez <[email-masked]>
Date: Sat, 23 Jan 2010 20:22:37 -0700

> which you can use kcachegrind to inspect.

Excellent. I could use this to track down why it's taking forever to load a
20,000 line message :)

-- 
If Java had true garbage collection, most programs would delete themselves upon execution.
-- Robert Sewell
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel