Subject: Re: [sup-devel] [PATCH] Add hook gpg-args to allow the user to add/remove flags

From: Rich Lane <[email-masked]>
Date: Sat, 27 Feb 2010 03:37:56 -0500

Applied to master.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Michael Stapelberg <[email-masked]>
Date: Wed, 17 Feb 2010 23:30:24 +0100

Hi,

attached you find a patch allowing the user to add/remove flags before running
GPG.  This is useful for specifying "--trust-model always" only for certain
GPG calls without introducing a whole bunch of new configuration options.
An example hook (which will add the ability to send encrypted email to
people to whom you have no trust relation):

  if args =~ /--encrypt/
    "--trust-model always #{args}"
  else
    args
  end

Please merge this patch for the next release

Best regards,
Michael