Subject: Re: [sup-devel] [sup] Maildir root: Keep labels in sync with maildir folders (#253)

From: Matthieu Rakotojaona <[email-masked]>
Date: Fri, 28 Mar 2014 08:47:35 +0100

Excerpts from Steven Schmeiser's message of 2014-03-28 00:40:18 +0100:
> I'm trying out the maildir-root branch, but get the following error:
> 
> undefined local variable or method `check_enable_experimental' for MaildirSub (deleted):Redwood::MaildirRoot::MaildirSub
> /usr/local/Cellar/ruby193/1.9.3-p545/lib/ruby/gems/1.9.1/gems/sup-999/lib/sup/maildirroot.rb:153:in `ensure_maildir'
> 
> I did a diff with an older version of maildir-root that I was using from gauteh's personal repository, but I didn't see anything obviously related to this that changed in maildirroot.rb.  Any suggestions?

Yes, the `check_enable_experimental` function is defined at the
maildirroot level, not the maildirsub level. The whole
e8bc811bb9188cbe9c2111b9515110a90278c46e commit is wrong.

If you feel adventurous you can fix this: the 2 lines are related to the
@maildirroot variable. I'll provide a patch a fix after $dayjob.

-- 
Matthieu Rakotojaona
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Steven Schmeiser <[email-masked]>
Date: Thu, 27 Mar 2014 19:40:18 -0400

Thanks,
steve 

On Mar 17, 2014, at 3:52, Gaute Hope <[email-masked]> wrote:

> Excerpts from Matthieu Rakotojaona's message of 2014-03-15 18:53:10 +0100:
>> Just opened https://github.com/sup-heliotrope/sup/tree/maildir-root
>> branch at 3f6bc97a14f8e87f1663f924aca5333617cbeec7 (your HEAD) to
>> track development of maildir-root. I'd like to use it in instead of
>> `gmail_source` because even if I break my sup, I can still read my
>> mails with any other MUA in the world.
>> 
>> --- Reply to this email directly or view it on GitHub:
>> https://github.com/sup-heliotrope/sup/pull/253#issuecomment-37732781
> 
> Cool. Feel free to push fixes there.
> 
> That was definetly a strong motivation for me as well.
> 
> - gaute
>

---

From: Matthieu Rakotojaona <[email-masked]>
Date: Thu, 03 Apr 2014 22:16:19 +0200

Hey Steven,

Turns out that $dayjob was far longer than expected.

I've pushed a PR at https://github.com/sup-heliotrope/sup/pull/286 that
should solve your issue. Could you please have a go at it ?

---

From: Gaute Hope <[email-masked]>
Date: Mon, 17 Mar 2014 08:52:14 +0100

- gaute