Subject: Re: [sup-devel] [PATCH] new hook: compose-from

From: "Edward Z. Yang" <[email-masked]>
Date: Tue, 09 Mar 2010 13:18:00 -0500

Excerpts from Michael Stapelberg's message of Tue Mar 09 12:54:18 -0500 2010:
> This hook is useful to use different names/addresses depending on the
> destination address, subject, etc. of the message. Example:
> 
>   if header["To"] and header["To"] =~ /^sup-(.*)@rubyforge\.org$/
>     Person.from_address "Michael Stapelberg <[email-masked]>"
>   end

I use before-edit.rb to do a similar thing.  Are the semantics the same?

Cheers,
Edward
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Michael Stapelberg <[email-masked]>
Date: Tue, 09 Mar 2010 23:21:46 +0100

Hi Edward,

> I use before-edit.rb to do a similar thing.  Are the semantics the same?
Roughly. header["To"] contains a full string (not only the entered address)
and you have to set header["From"] to a string instead of a Person object.

But yeah, seems like you are right and this hook is redundant.

Best regards,
Michael

---

From: Michael Stapelberg <[email-masked]>
Date: Tue, 09 Mar 2010 18:54:18 +0100

Hi,

Best regards,
Michael