Subject: Re: [sup-devel] [PATCH] Bugfix: Don\xe2\x80\x99t call Ncurses.getch when in shell\x96out mode

From: Rich Lane <[email-masked]>
Date: Sat, 27 Feb 2010 03:23:39 -0500

Excerpts from Michael Stapelberg's message of 2010-02-18 22:26:37 -0500:
> Hi,
> 
> (at least for me) the attached patch finally fixes the pinentry-ncurses
> problems we were still having (as soon as you press a key, the screen is
> garbage).
> 
> To quote the commit message:
> 
>   Previously, when using threads, Ncurses.getch was called while
>   the gpg pinentry was running (as an example of using the shell_out
>   method). Now, the Ncurses mutex will be used to wait until shell_out
>   mode is finished.
> 
> Please have a look if this patch is working for you and merge it for the next
> release.
> 
> Best regards,
> Michael

What's the reason for passing the BufferManager singleton as an
argument?

What does "drop the input" mean?
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Michael Stapelberg <[email-masked]>
Date: Fri, 19 Feb 2010 04:26:37 +0100

Hi,

Best regards,
Michael

---

From: Rich Lane <[email-masked]>
Date: Sat, 27 Feb 2010 14:03:31 -0500

Excerpts from William Morgan's message of 2010-02-27 14:00:30 -0500:
> Reformatted excerpts from Rich Lane's message of 2010-02-27:
> > The reason we use these ugly singleton *Manager objects is to avoid
> > exactly this kind of plumbing. Since Ncurses is outside the Redwood
> > namespace you'll need to refer to it as Redwood::BufferManager.
> 
> I know it's fashionable to call singletons ugly nowadays, but I've never
> quite bought into it. Classes are singletons too, and no one calls them
> ugly...
> 
> (Well, I do, but for different reasons.)

You've never tried to write an Index testsuite :).
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Sat, 27 Feb 2010 13:12:19 -0500

Excerpts from Michael Stapelberg's message of 2010-02-27 07:48:39 -0500:
> Hi Rich,
> 
> Excerpts from Rich Lane's message of Sa Feb 27 09:23:39 +0100 2010:
> I am passing the BufferManager because I could not figure out how to access
> it from inside the Ncurses module. Maybe there is a better way, if so, please
> tell me :-).

> It means returning nil instead of Ncurses.getch, so maybe a better way of
> saying it is "We do not check for input because it would restart Ncurses
> while in shell-out mode".

Ok, that's how I read the code. When I saw "drop" in the comment I
thought it was going to read input and throw it away.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Michael Stapelberg <[email-masked]>
Date: Sat, 27 Feb 2010 13:48:39 +0100

Hi Rich,

Best regards,
Michael

---

From: Michael Stapelberg <[email-masked]>
Date: Sat, 27 Feb 2010 20:27:45 +0100

Hi Rich,

> namespace you'll need to refer to it as Redwood::BufferManager.
Alright. Should I change the patch and re-send it or can you change
these little details?

Best regards,
Michael

---

From: Rich Lane <[email-masked]>
Date: Sat, 27 Feb 2010 15:14:27 -0500

> Alright. Should I change the patch and re-send it or can you change

I'll handle it. Applied to master.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Sat, 27 Feb 2010 14:00:30 -0500

(Well, I do, but for different reasons.)
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Sat, 27 Feb 2010 14:29:48 -0500

> You've never tried to write an Index testsuite :).

What is complicated about it?
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel