Subject: [sup-devel] check keys before sending

From: Troy Sankey <[email-masked]>
Date: Sat, 10 May 2014 01:23:11 -0700

Hi sup developers,

Recently I sent an encrypted message to a group of recipients, thinking
that all their keys were still valid.  However, one of them had an
expired key, so the message was not encrypted to that recipient and he
could not read it.

I want sup to prompt the user about potentially invalid keys before
sending a message.  I think the code will look something like this:

diff --git a/lib/sup/crypto.rb b/lib/sup/crypto.rb
index fd8f824..88ae3cc 100644
--- a/lib/sup/crypto.rb
+++ b/lib/sup/crypto.rb
@@ -167,6 +167,14 @@ EOS
                                {:operation => "encrypt", :options => gpg_opts}) || gpg_opts
     recipients = to + [from]
     recipients = HookManager.run("gpg-expand-keys", { :recipients => recipients }) || recipients
+
+    # make sure all recipients can be encrypted-to
+    recipients.each do |recipient|
+      if GPGME::Key.find(:public, recipient).length == 0 and !BufferManager.ask_yes_or_no("Could not encrypt to #{recipient}. Really send?")
+        raise Error, "Send message cancelled."
+      end
+    end
+
     begin
       if GPGME.respond_to?('encrypt')
         cipher = GPGME.encrypt(recipients, format_payload(payload), gpg_opts)

I have not tested this patch, so if it looks wrong then it probably is!
Does anybody have any thoughts on this feature?

Troy
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Gaute Hope <[email-masked]>
Date: Sat, 10 May 2014 18:54:58 +0200

I think this can be included if you test and verify the patch. Definetely
very useful.

On Sat, May 10, 2014 at 10:23 AM, Troy Sankey <[email-masked]> wrote:

> +      if GPGME::Key.find(:public, recipient).length == 0 and
> !BufferManager.ask_yes_or_no("Could not encrypt to #{recipient}. Really
> send?")