Subject: Re: [sup-devel] [PATCH] only open mail files in binary mode on Ruby 1.9

From: William Morgan <[email-masked]>
Date: Mon, 18 Jan 2010 08:05:45 -0500

Reformatted excerpts from Gaute Hope's message of 2010-01-18:
> See issue 36, its a bit big: problems with subjects, tab completion,
> and recipients.

This is an unrelated issue, though I agree it's important and should be
addressed.

Rich sent out a patch a while ago that added the special encoding pragma
to a bunch of source files. That might fix this, as might putting a "u"
at the end of every Regexp in the source. :(
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Tue, 05 Jan 2010 14:05:21 -0800

Applied to ruby-1.9-encodings. I added another commit to make it pass
through any block, otherwise it was silently failing on my 1.8.7 setup.
Hope it still works for 1.9. :) Thanks!
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Gaute Hope <[email-masked]>
Date: Mon, 18 Jan 2010 09:38:03 +0100

Excerpts from William Morgan's message of 2010-01-18 00:12:50 +0100:
> Reformatted excerpts from William Morgan's message of 2010-01-06:
> > The internet claims that using "rb" and "wb" works for both 1.8.5 and
> > 1.9.1, but I haven't tried it.
> 
> I've done this in ruby-1.9-encodings and remerged into next.
> 
> Those of you tracking next with 1.9, please let me know if you
> experience any weird encoding errors.
> 
> (And those with 1.8, as well, I suppose.)

See issue 36, its a bit big: problems with subjects, tab completion, and
recipients.

- gaute

---

From: William Morgan <[email-masked]>
Date: Wed, 06 Jan 2010 08:35:55 -0800

---

From: William Morgan <[email-masked]>
Date: Sun, 17 Jan 2010 18:12:50 -0500

---

From: Rich Lane <[email-masked]>
Date: Mon, 4 Jan 2010 11:45:42 -0800

---
 lib/sup/maildir.rb     |    4 ++--
 lib/sup/mbox/loader.rb |    4 ++--
 lib/sup/util.rb        |    7 +++++++
 3 files changed, 11 insertions(+), 4 deletions(-)

diff --git a/lib/sup/maildir.rb b/lib/sup/maildir.rb
index 0852576..b2c5847 100644
--- a/lib/sup/maildir.rb
+++ b/lib/sup/maildir.rb
@@ -59,7 +59,7 @@ class Maildir < Source
         File.stat(tmp_path)
       rescue Errno::ENOENT #this is what we want.
         begin
-          File.open(tmp_path, 'wb:BINARY') do |f|
+          File.open_binary(tmp_path, 'w') do |f|
             yield f #provide a writable interface for the caller
             f.fsync
           end
@@ -207,7 +207,7 @@ private
   def with_file_for id
     fn = @ids_to_fns[id] or raise OutOfSyncSourceError, "No such id: #{id.inspect}."
     begin
-      File.open(fn, 'rb:BINARY') { |f| yield f }
+      File.open_binary(fn, 'r') { |f| yield f }
     rescue SystemCallError, IOError => e
       raise FatalSourceError, "Problem reading file for id #{id.inspect}: #{fn.inspect}: #{e.message}."
     end
diff --git a/lib/sup/mbox/loader.rb b/lib/sup/mbox/loader.rb
index ec28d3b..557c13b 100644
--- a/lib/sup/mbox/loader.rb
+++ b/lib/sup/mbox/loader.rb
@@ -22,7 +22,7 @@ class Loader < Source
       raise ArgumentError, "not an mbox uri" unless uri.scheme == "mbox"
       raise ArgumentError, "mbox URI ('#{uri}') cannot have a host: #{uri.host}" if uri.host
       raise ArgumentError, "mbox URI must have a path component" unless uri.path
-      @f = File.open uri.path, 'rb:BINARY'
+      @f = File.open_binary uri.path, 'r'
       @path = uri.path
     else
       @f = uri_or_fp
@@ -114,7 +114,7 @@ class Loader < Source
 
   def store_message date, from_email, &block
     need_blank = File.exists?(@filename) && !File.zero?(@filename)
-    File.open(@filename, "ab:BINARY") do |f|
+    File.open_binary(@filename, "a") do |f|
       f.puts if need_blank
       f.puts "From #{from_email} #{date.rfc2822}"
       yield f
diff --git a/lib/sup/util.rb b/lib/sup/util.rb
index c27e527..e8f3289 100644
--- a/lib/sup/util.rb
+++ b/lib/sup/util.rb
@@ -691,3 +691,10 @@ class Iconv
     end
   end
 end
+
+class File
+  def self.open_binary filename, mode
+    mode += 'b:BINARY' if String.method_defined? :encoding
+    open filename, mode
+  end
+end
-- 
1.6.3.3