Subject: [sup-devel] updated edge branch

From: Rich Lane <[email-masked]>
Date: Sun, 21 Feb 2010 19:20:52 -0500

There are a bunch of patches that haven't been merged to mainline yet,
so I merged them to my edge branch. I didn't look too hard at them so
don't assume that this branch could be merged to mainline as-is.

git://github.com/rlane/sup.git

git log --no-merges --abbrev-commit --pretty=oneline mainline/next...edge
e3821be... Added support for multiple sent sources.
21070d5... index-mode-date-widget hook for rendering dates in thread index
5f67e69... Implement inline GPG
0d1fe80... Make automatic jumping to first/next open message configurable
f6c0f29... Bugfix: Don<E2><80><99>t call Ncurses.getch when in shell_out mode
c8f83d6... Add hook gpg-args to allow the user to add/remove flags
3aabf1a... Added crypto-settings hook
411b7ce... Publishing hook
287c281... Use multiple body arrays when calling before-edit for each reply type
3da9c18... Add config option to limit text wrapping width
b942caf... prevent "year too big to marshal" crashes
9819900... flush index on idle
8246259... catch xapian query parser exceptions and display them to the user
31141e2... fix missing parentheses warning
923521d... fix participants queries
c30d2fe... Conditionally define Fixnum#ord
7f4830a... poll updates accumulate while idle
9951acf... idle and unidle updates
a76c577... fix textfield truncation
979f64a... show (recipients) instead of lone "me"
a074184... dont restrict colors to those in Colormap::DEFAULT_COLORS
3a96053... configurable color highlights
02b1926... dont check thread-index-mode dirtiness on every keypress
afe8eb8... enable ruby-prof with SUP_PROFILE environment variable
4af9a93... keybindings hook
1fb13f5... add keymap rebinding support
23e872a... make mode keymap easily accessible to hooks
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Tero Tilus <[email-masked]>
Date: Mon, 22 Feb 2010 07:48:30 +0200

Rich Lane, 2010-02-22 02:20:
> There are a bunch of patches that haven't been merged to mainline
> yet, so I merged them to my edge branch.

Thanks.  Now I don't have to (re)integrate them to my daily sup all
the time.

> I didn't look too hard at them so don't assume that this branch
> could be merged to mainline as-is.

Was hookifying missing attachment detector intentionally left out?
http://github.com/terotil/sup/commit/ae317d351b9b1e4210d472cfe43b8e60cd4257c4

-- 
Tero Tilus ## 050 3635 235 ## http://tero.tilus.net/
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel