Subject: [sup-devel] [Heliotrope] when importing mail from sup, label "killed" doesn't get changed to "muted"

From: William Morgan <[email-masked]>
Date: Mon, 09 Jan 2012 15:37:19 -0800

Excerpts from Michael Stapelberg's message of 2012-01-08 13:27:11 -0800:
> I recently imported my mail from sup to heliotrope and noticed that I
> had a lot of threads in my inbox which were killed in sup. A quick
> glance at the source of heliotrope revealed that you made the label
> name consistent with GMail and renamed it to "muted". However, as the
> subject says, when importing, this label is not changed.

Thanks for the report. I will fix this so that the import process
converts the label automatically.
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Michael Stapelberg <[email-masked]>
Date: Sun, 08 Jan 2012 21:27:11 +0000

Hey again,

I recently imported my mail from sup to heliotrope and noticed that I had a lot
of threads in my inbox which were killed in sup. A quick glance at the source of
heliotrope revealed that you made the label name consistent with GMail and
renamed it to "muted". However, as the subject says, when importing, this label
is not changed.

For a quick fix after importing the messages, do the following in
heliotrope-console:

$ ruby -Ilib bin/heliotrope-console --dir /path/to/mailstore

metaindex.set_query Query.new("body", "~killed")
results = metaindex.get_some_results(metaindex.count_results)

for result in results do
   labels = result[:labels]
   labels.delete("killed")
   labels.add("muted")
   metaindex.update_thread_labels(result[:thread_id], labels)
end

Best regards,
Michael

---

From: William Morgan <[email-masked]>
Date: Sat, 14 Jan 2012 20:54:36 -0800

> converts the label automatically.

This should be fixed.