Subject: [sup-devel] [Heliotrope] Bug: Cannot use UTF-8 characters in subject

From: Michael Stapelberg <[email-masked]>
Date: Sun, 08 Jan 2012 21:23:06 +0000

Hey,

I tried sending an email to this list and used an UTF-8 character in the
message subject. Turnsole (or RMail?) doesn’t like that, and I got the
following exception:

$ ruby -I lib -I ../heliotrope/lib bin/turnsole
/home/michael/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require': iconv will be deprecated in the future, use String#encode instead.
/home/michael/.rvm/gems/ruby-1.9.3-p0@sup2011-11-18/gems/rmail-1.0.0/lib/rmail/header.rb:81:in `=~': incompatible encoding regexp match (ASCII-8BIT regexp with UTF-8 string) (Encoding::CompatibilityError)
	from /home/michael/.rvm/gems/ruby-1.9.3-p0@sup2011-11-18/gems/rmail-1.0.0/lib/rmail/header.rb:81:in `parse'
	from /home/michael/.rvm/gems/ruby-1.9.3-p0@sup2011-11-18/gems/rmail-1.0.0/lib/rmail/parser.rb:233:in `block in parse_header'
	from /home/michael/.rvm/gems/ruby-1.9.3-p0@sup2011-11-18/gems/rmail-1.0.0/lib/rmail/parser.rb:229:in `each'
	from /home/michael/.rvm/gems/ruby-1.9.3-p0@sup2011-11-18/gems/rmail-1.0.0/lib/rmail/parser.rb:229:in `parse_header'
	from /home/michael/.rvm/gems/ruby-1.9.3-p0@sup2011-11-18/gems/rmail-1.0.0/lib/rmail/parser.rb:194:in `parse_low'
	from /home/michael/.rvm/gems/ruby-1.9.3-p0@sup2011-11-18/gems/rmail-1.0.0/lib/rmail/parser.rb:183:in `parse'
	from /home/michael/.rvm/gems/ruby-1.9.3-p0@sup2011-11-18/gems/rmail-1.0.0/lib/rmail/parser.rb:331:in `parse'
	from /home/michael/.rvm/gems/ruby-1.9.3-p0@sup2011-11-18/gems/rmail-1.0.0/lib/rmail/parser.rb:345:in `read'
	from /home/michael/turnsole/lib/turnsole/modes/edit-message-mode.rb:273:in `parse_file'
	from /home/michael/turnsole/lib/turnsole/modes/edit-message-mode.rb:166:in `edit_message!'
	from /home/michael/turnsole/lib/turnsole/modes/compose-mode.rb:19:in `edit_message!'
	from /home/michael/turnsole/lib/turnsole/modes/compose-mode.rb:47:in `spawn_nicely'
	from /home/michael/turnsole/lib/turnsole/global.rb:100:in `do'
	from /home/michael/turnsole/lib/turnsole/input.rb:41:in `handle'
	from /home/michael/turnsole/lib/turnsole/ui.rb:69:in `block in step'
	from /home/michael/turnsole/lib/turnsole/ui.rb:100:in `block in spawn_fiber'

Also, I noticed that the tempfile which turnsole used to store my mail was gone
afterwards :(. The message was not saved as a draft in Heliotrope either. GMail
does that pretty well, so it would be great if we could keep up here.

Best regards,
Michael
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Mon, 09 Jan 2012 15:23:18 -0800

> message subject. Turnsole (or RMail?) doesn’t like that, and I got the

Thanks. I'm hoping we can fix this with the mail gem, as opposed to modyfing
RMail directly.

> does that pretty well, so it would be great if we could keep up here.

Yeah. As a first step we should at least move away from the Ruby tempfile
library, which deletes the file when a GC happens, and explicitly delete the
tempfiles only after success.

Can you please file a bug report for both of these on the issues page?
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel