Subject: [sup-devel] [PATCH] Fix 1.9-ism use of Array.count

From: Ben Walton <[email-masked]>
Date: Thu, 13 May 2010 21:08:05 -0400

Use the size method of array rather than the 1.9 specific count in
message body parsing.

Signed-off-by: Ben Walton <[email-masked]>
---
 lib/sup/message.rb |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/lib/sup/message.rb b/lib/sup/message.rb
index 0bda5b1..521f00f 100644
--- a/lib/sup/message.rb
+++ b/lib/sup/message.rb
@@ -554,7 +554,7 @@ private
 
       sig = lines.between(GPG_SIGNED_START, GPG_SIG_END)
       payload = RMail::Message.new
-      payload.body = sig[1, sig.count-2].join("\n")
+      payload.body = sig[1, sig.size-2].join("\n")
       return [CryptoManager.verify(nil, msg, false), message_to_chunks(payload)].flatten.compact
     end
 
-- 
1.7.0

_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Thu, 13 May 2010 22:32:10 -0400

Applied to inline-gpg and branch merged to master.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel