Subject: [sup-devel] [PATCH] mbox: fix date format

From: Sascha Silbe <[email-masked]>
Date: Thu, 8 Jul 2010 12:28:07 +0000

The date format used in all (known/common) variations is that of Unix/POSIX
asctime(), not the RFC 822 / RFC 2822 Date: header format.

Using an incorrect date format causes at least mutt, mb2md and Python
UnixMailbox (but not PortableUnixMailbox) to either reject the mailbox or show
it as empty.

References:
http://homepage.ntlworld.com./jonathan.deboynepollard/FGA/mail-mbox-formats.html
http://www.qmail.org/man/man5/mbox.html

Signed-off-by: Sascha Silbe <[email-masked]>
---
 lib/sup/mbox.rb |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/lib/sup/mbox.rb b/lib/sup/mbox.rb
index 2bf32ea..452519d 100644
--- a/lib/sup/mbox.rb
+++ b/lib/sup/mbox.rb
@@ -140,7 +140,7 @@ class MBox < Source
     need_blank = File.exists?(@filename) && !File.zero?(@filename)
     File.open(@filename, "ab") do |f|
       f.puts if need_blank
-      f.puts "From #{from_email} #{date.rfc2822}"
+      f.puts "From #{from_email} #{date.asctime}"
       yield f
     end
   end
-- 
1.7.1

_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Mon, 12 Jul 2010 22:10:51 -0400

Applied to master.