Subject: Re: [sup-devel] [issue39] Exception running Sup while following the Instructions to fix UTF-8

From: William Morgan <[email-masked]>
Date: Sun, 03 Jan 2010 14:00:28 -0800

Reformatted excerpts from anonymous's message of 2009-12-31:
> --- RuntimeError from thread: main
> no Redwood::SentManager instance defined in method call to i_am_the_instance!
> ./lib/sup/util.rb:512:in `method_missing'
> /usr/lib/ruby/1.8/sup/sent.rb:10:in `initialize'
> ./lib/sup/util.rb:524:in `new'
> ./lib/sup/util.rb:524:in `init'
> ./lib/sup.rb:124:in `start'
> bin/sup:143

Soemthing is screwey with your setup---you're loading most files from
./lib, but sent.rb is being loaded from an old version of an installed
gem. Are you missing ./lib/sent.rb? If not, does this still happen if
you uninstall the Sup gem?
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: anonymous <[email-masked]>
Date: Thu, 31 Dec 2009 20:23:15 +0000

New submission from anonymous:

Sup!

I was following [these][http://sup.rubyforge.org/wiki/wiki.pl?UTF8] instructions
to fix the UTF-8 encoding problem, and when I ran `ruby -Ilib bin/sup`, I got
the following exception:

----------
messages: 101
nosy: anonymous
priority: bug
ruby_version: 1.8
status: unread
sup_version: git
title: Exception running Sup while following the Instructions to fix UTF-8

_________________________________________
Sup issue tracker <[email-masked]>
<http://masanjin.net/sup-bugs/issue39>
_________________________________________
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel