Subject: Re: [sup-devel] [PATCHES] reply-mode, signatures and account selector

From: Damien Leone <[email-masked]>
Date: Wed, 09 Jun 2010 15:15:11 +0200

I noticed an error in the third patch.
Please consider the one attached to *this* email.

Regards,

Excerpts from Damien Leone's message of mer. juin 09 14:53:16 +0200 2010:
> Sup guys,
> 
> Three patches are attached to this email, the commit messages should
> be self explanatory but here are some more details:
> 
> As the first patch changes the way headers are handled in reply-mode
> there is a regression in the before-edit hook possibilities.
> Before, we could write something like:
> 
> if header["Cc"] == "foo"
>    header["Bcc"] = "bar"
> end
> 
> Hence, switching the reply-to type using the selector would have
> changed the Bcc field if a type using Cc was selected.
> 
> This would be no longer possible since there is now only one "set" of
> headers running the hook, however if you properly wrote your reply-to
> hook you can select the reply type you want and the previous code
> will be working as expected.
> 
> On the other hand (in my opinion), the reply-mode now handles better
> its job, that is to say changing To and Cc without interfering with
> other fields that might have been edited manually by the user.
> 
> I asked rlane about this on IRC:
> > <dleone> what is the reason for the before-edit hook being runned on @bodies and @header for each Reply-To types?
> > <rlane> that's so that when you switch reply-to type the right signature/etc is displayed
> 
> I see no regression regarding this in the patch, so it should be okay.
> 
> Other patches add an account selector in edit-mode (it is useful to me
> and I saw requests for such a feature) and a better signature handling
> regarding the edit_signature option.
> 
> Regards,

--
Damien Leone <[email-masked]>

Web: http://dleone.fensalir.fr/
GPG: 0x82EB4DDF
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Damien Leone <[email-masked]>
Date: Sat, 03 Jul 2010 19:22:42 +0200

Any reviewer for these patches?

Thanks.

---

From: Damien Leone <[email-masked]>
Date: Wed, 09 Jun 2010 14:53:16 +0200

Sup guys,

if header["Cc"] == "foo"
   header["Bcc"] = "bar"
end

Regards,