Subject: Re: [sup-devel] Fwd: Re: Sup 0.10 released

From: Rich Lane <[email-masked]>
Date: Mon, 25 Jan 2010 17:05:49 -0500

Excerpts from William Morgan's message of 2010-01-25 16:19:13 -0500:
> I'm seeing a weird behavior with the xapian-full gem, and so is this
> guy. The installation claims it fails, but it actually succeeds. The
> spec file is not copied over after installation, so `gem list` doesn't
> show it, but if you require 'xapian' it actually does pick up the code,
> even after the failed installation.
> 
> Ideas?

This has been reported before but I haven't figured out what's going on.
I pushed the source of the xapian-full gem to git://github.com/rlane/xapian-full
in case anyone else wants to take a crack at this.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Mon, 25 Jan 2010 18:37:24 -0500

> in case anyone else wants to take a crack at this.

I think I fixed it. Please try xapian-full 1.1.3.1 from gemcutter.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Mon, 25 Jan 2010 19:35:44 -0500

Excerpts from Mark Alexander's message of 2010-01-25 19:21:14 -0500:
> On Mon, Jan 25, 2010 at 6:37 PM, Rich Lane <[email-masked]> wrote:
> Can you describe what you did to fix it?  I spent several hours
> trying to fix this a while back and gave up.

It turns out gem expects extconf.rb to create a Makefile, but mine was
just doing the compile itself. Gem also accepts Rakefiles for building
extensions, so I moved the code into a minimal Rakefile. I also added
the gemspec to the manifest.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Mark Alexander <[email-masked]>
Date: Mon, 25 Jan 2010 19:21:14 -0500

---

From: William Morgan <[email-masked]>
Date: Tue, 26 Jan 2010 08:22:09 -0500

> I think I fixed it. Please try xapian-full 1.1.3.1 from gemcutter.

Works great. Nice one.

I'm going to release an 0.10.2 that has deps on that and ncursesw.
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Nicolas Pouillard <[email-masked]>
Date: Tue, 26 Jan 2010 07:50:30 -0800 (PST)

> I'm going to release an 0.10.2 that has deps on that and ncursesw.

Yes worked great for me too.

-- 
Nicolas Pouillard
http://nicolaspouillard.fr
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Mon, 25 Jan 2010 16:19:13 -0500

Ideas?

--- Begin forwarded message from Andrea Fazzi ---
From: Andrea Fazzi <[email-masked]>
To: ruby-talk <[email-masked]>
Date: Mon, 25 Jan 2010 05:32:10 -0500
Subject: Re: Sup 0.10 released

William Morgan wrote:
> I'm pleased to announce the release of Sup 0.10. This version is
> frickin' awesome because not only do we have Ruby 1.9 support, the
> Xapian backend is now the default!  The next version will discard Ferret
> like a used rag.

I had issues installing xapian-full gem on my ubuntu box running MRI
ruby1.8. The installation fails building native extension even if it 
seems that all the C stuff get compiled correctly. BTW, I solved the 
issue in this way:

sudo gem install xapian-full
cd /usr/lib/ruby/gems/1.8/gems/xapian-full-1.1.3/
sudo rake build
sudo mv xapian-full.gemspec ../../specifications/

andrea@ubuntu-desktop:~$ irb
irb(main):001:0> require 'rubygems'
=> true
irb(main):002:0> require 'xapian'
=> true

Thanks for this great software!

Cheers,
Andrea