Subject: [sup-devel] pass //IGNORE to iconv

From: Alvaro Herrera <[email-masked]>
Date: Tue, 09 Nov 2010 12:27:06 -0300

With the current code, an encoding failure means we see (and quote)
stuff like \xab\xbc\x07 in the text.  Using the //IGNORE flag allows the
code to ignore broken chars instead of displaying large amounts of junk.

I note that the text containing broken chars is coming from external
sources, so there's nothing that could be done locally to fix it.

-- 
Álvaro Herrera <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Sun, 14 Nov 2010 23:17:59 -0500

Applied to master.