Subject: Re: [sup-devel] [PATCH] I can haz moar hooks: attachment-mentioned, index-mode-date-widget

From: Tero Tilus <[email-masked]>
Date: Mon, 22 Feb 2010 10:09:24 +0200

Tero Tilus, 2010-02-22 10:07:
> Amended patch attached.

Didn't pass my own test.  :D
Better luck this time with the attachment.

-- 
Tero Tilus ## 050 3635 235 ## http://tero.tilus.net/
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Tero Tilus <[email-masked]>
Date: Mon, 22 Feb 2010 10:07:34 +0200

Rich Lane, 2010-02-22 09:22:
> Wouldn't the detect-missing-attachment hook patch cause a regression
> for people who don't write their own hook?

Oops.  It definitely would.  Amended patch attached.

---

From: Rich Lane <[email-masked]>
Date: Sat, 27 Feb 2010 03:11:54 -0500

Branch mentions-attachments-hook, merged into next.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Mon, 22 Feb 2010 02:22:25 -0500

Excerpts from Tero Tilus's message of 2010-01-21 20:32:00 -0500:
> William Morgan, 2009-12-21 15:38:
> > Reformatted excerpts from Tero Tilus's message of 2009-12-19:
> > > The detect-missing-attachment hook is pretty self evident but what you
> > > had in mind for the dates?  Formatter for the thread-index-mode date
> > > widget maybe?
> > 
> > Exactly. We already have index-mode-size-widget, so
> > index-mode-date-widget would be analogous.
> 
> Here they are, finally...

Wouldn't the detect-missing-attachment hook patch cause a regression for
people who don't write their own hook?
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Tero Tilus <[email-masked]>
Date: Thu, 04 Feb 2010 09:06:03 +0200

Tero Tilus, 2010-01-22 03:32:
> > > detect-missing-attachment hook
> > 
> > index-mode-date-widget
> 

Any feedback on these?  Do they need any tuning?

---

From: Rich Lane <[email-masked]>
Date: Sat, 27 Feb 2010 03:16:48 -0500

Branch date-widget-hook, merged to next.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Tero Tilus <[email-masked]>
Date: Fri, 22 Jan 2010 03:32:00 +0200