Subject: [sup-devel] Snippet: Copy unread messages to maildir

From: Michael Stapelberg <[email-masked]>
Date: Mon, 25 Oct 2010 22:32:18 +0200

Hi,

I thought it would be a good idea to copy the unread messages from my sup inbox
to a separate maildir to access it from my phone. Turns out that once you are
spoiled with sup, you cannot go back to "normal" mail clients (k-9 mail in this
case) ;-).

Nevertheless, I thought maybe somebody could use the code I wrote. I’m
attaching it to this mail, but beware, it still has a bug: It crashes when
exporting messages sometimes. It also uses absolute paths.

Best regards,
Michael
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Ben Walton <[email-masked]>
Date: Mon, 25 Oct 2010 20:50:00 -0400

Excerpts from Michael Stapelberg's message of Mon Oct 25 16:32:18 -0400 2010:

> I thought it would be a good idea to copy the unread messages from
> my sup inbox to a separate maildir to access it from my phone. Turns
> out that once you are spoiled with sup, you cannot go back to
> "normal" mail clients (k-9 mail in this case) ;-).

I just started doing this too.  My approach is different though.  I'm
using procmail to :0c (copy) any mail that is addressed directly to me
into the Inbox.  All other mail is diverted to folders like
.incoming.2010.10/.  (I have a hook that automatically adds new
sources as they appear...)

Now, if I could get my phone to supply In-Reply-To and friends, my sup
interaction while mobile would be in much better shape!

Thanks
-Ben
--
Ben Walton
Systems Programmer - CHASS
University of Toronto
C:416.407.5610 | W:416.978.4302