Subject: Re: [sup-devel] [PATCH] Bugfix: Correctly split list of mail addresses

From: Rich Lane <[email-masked]>
Date: Wed, 13 Oct 2010 21:10:50 -0400

Applied to master.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Gregor Hoffleit <[email-masked]>
Date: Tue, 12 Oct 2010 18:15:59 +0200

>From the commit message:

    split_on_commas() fails to work correctly for wrapped header lines:

	Cc: John Doe <[email-masked]>, Foo Bar
	    <[email-masked]>

    Sup parsed this (in lib/sup/person.rb, Person.from_address_list) as:

	Cc: John Doe <[email-masked]>,
	    foo.bar <[email-masked]>

    I fixed this by normalizing the whitespace before working the
    regex in split_on_commas.

Regards,
    Gregor Hoffleit