Subject: Re: [sup-devel] [PATCH] Respect source.archived? in poll.

From: Rich Lane <[email-masked]>
Date: Wed, 02 Jun 2010 23:58:20 -0400

Applied to master.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: [email-masked]
Date: Wed, 26 May 2010 14:48:12 -0700

From: Anthony Martinez <[email-masked]>

[14:31:51] <mtp> i have some sources marked as pre-archived, but it isn't obeying that
[14:38:02] <mtp> looks like 51789907cfcf80b5edb4d597c91a7c888ce5e003 broke it in the first hunk of lib/sup/poll.rb

This appears to fix it.
---
 lib/sup/poll.rb |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)

diff --git a/lib/sup/poll.rb b/lib/sup/poll.rb
index 20931f5..607d06a 100644
--- a/lib/sup/poll.rb
+++ b/lib/sup/poll.rb
@@ -158,6 +158,7 @@ EOS
           m = Message.build_from_source source, args[:info]
           old_m = Index.build_message m.id
           m.labels += args[:labels]
+          m.labels.delete :inbox  if source.archived?
           m.labels.delete :unread if source.read?
           m.labels.delete :unread if m.source_marked_read? # preserve read status if possible
           m.labels.each { |l| LabelManager << l }
-- 
1.6.6