Subject: [sup-devel] Label colors support

From: Matias Aguirre <[email-masked]>
Date: Tue, 03 Aug 2010 19:14:13 -0300

Hi,

Been an user for some time now, congrats for the good work. But there's
something I've missed from mutt and is the ability to customize inbox
emails colors, I've used to colorize by source address or domain.

Attached is a patch (first ruby code in a lot of time) with needed
changes to allow colors by label and produces a good and quick feedback.

Cheers,
Matías
--
Matías Aguirre <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Matias Aguirre <[email-masked]>
Date: Thu, 19 Aug 2010 18:04:36 -0300

Excerpts from Sascha Silbe's message of Thu Aug 19 05:13:34 -0300 2010:
> Excerpts from Matias Aguirre's message of Wed Aug 04 00:14:13 +0200 2010:
> 
> Nice idea! Would you mind prefixing (or suffixing) the color name with
> "label" to prevent name clashes and make it clearer what the colors are
> used for?

Indeed that will be clearer, here's the changeset:
http://github.com/omab/sup/commit/1a96a0ae856076d645a11e0b7d94858851343e27

Thanks,
Matías

> Sascha
--
Matías Aguirre <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Matias Aguirre <[email-masked]>
Date: Wed, 04 Aug 2010 13:50:00 -0300

Sorry, wrong github link, this is the correct changeset:
http://github.com/omab/sup/commit/865bc2b77038f612ccf0c5174021f001811116a4

Excerpts from Matias Aguirre's message of Wed Aug 04 13:41:26 -0300 2010:
> Forgot to mention that colors are defined in colors.yaml using label
> names and common attributes:
> 
>     :somelabel:
>         :bg: ...
>         :fg: ...
>         :attrs:
>             ...
> 
> Also, I've forked sup on my github account, changeset can be checked here
> http://github.com/omab/sup/commit/a6f9bfb5d1f23aa6376ad725e64a3e2c3066663d
> 
> Thanks,
> Matías
> 
> Excerpts from Matias Aguirre's message of Tue Aug 03 19:14:13 -0300 2010:
> > Hi,
> >

---

From: Sascha Silbe <[email-masked]>
Date: Thu, 19 Aug 2010 10:13:34 +0200

Sascha

--
http://sascha.silbe.org/
http://www.infra-silbe.de/
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Michael Stapelberg <[email-masked]>
Date: Wed, 26 Jan 2011 21:20:55 +0100

Hi Matias,

> http://github.com/omab/sup/commit/1a96a0ae856076d645a11e0b7d94858851343e27
I just created a branch 'label-colors' and merged it into 'next' of
sup/mainline (based on your merged request on gitorious).

Thanks for contributing!

Best regards,
Michael

---

From: Matias Aguirre <[email-masked]>
Date: Wed, 04 Aug 2010 13:41:26 -0300

:somelabel:
        :bg: ...
        :fg: ...
        :attrs:
            ...

Thanks,
Matías

---

From: Matias Aguirre <[email-masked]>
Date: Wed, 26 Jan 2011 19:21:26 -0200

> sup/mainline (based on your merged request on gitorious).

That's great, thanks!