Subject: Re: [sup-devel] [PATCH] fix crash in sup-dump if the default sent source is used

From: Rich Lane <[email-masked]>
Date: Fri, 02 Jul 2010 22:31:59 -0400

Applied to master.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Sascha Silbe <[email-masked]>
Date: Tue, 29 Jun 2010 10:12:05 +0200

This fixes a crash in sup-dump if the index contains a "sent" message and
no "sent" folder has been explicitly configured in the config file
(so it hasn't been added to sources.yaml).

Signed-off-by: Sascha Silbe <[email-masked]>
---
 bin/sup-dump |    7 +++++++
 1 files changed, 7 insertions(+), 0 deletions(-)

diff --git a/bin/sup-dump b/bin/sup-dump
index d6a06e4..953b6e5 100755
--- a/bin/sup-dump
+++ b/bin/sup-dump
@@ -19,9 +19,16 @@ Usage:
 EOS
 end
 
+$config = Redwood::load_config Redwood::CONFIG_FN
 index = Redwood::Index.init
 Redwood::SourceManager.init
 index.load
+Redwood::SentManager.init $config[:sent_source] || 'sup://sent'
+if(s = Redwood::SourceManager.source_for Redwood::SentManager.source_uri)
+  Redwood::SentManager.source = s
+else
+  Redwood::SourceManager.add_source Redwood::SentManager.default_source
+end
 
 index.each_message :load_spam => true, :load_deleted => true, :load_killed => true do |m|
   puts "#{m.id} (#{m.labels.to_a.sort_by { |l| l.to_s } * ' '})"
-- 
1.6.5