Subject: Re: [sup-devel] Ruby 1.9.2 Rakefile & LOAD_PATH

From: Gaute Hope <[email-masked]>
Date: Mon, 22 Aug 2011 13:30:31 +0200

Excerpts from Matti Eiden's message of 2011-03-21 19:38:31 +0100:
> I posted on sup-talk in last December about an issue in the Rakefile
> of sup when it comes to Ruby 1.9.2. The whole thing boils down to
> this: https://rails.lighthouseapp.com/projects/8994/tickets/2921
> 
> Made merge request @ http://gitorious.org/sup/mainline/merge_requests/11

Hi,

this still persists.. here is another alternative using
require_relative. Please apply original or my modified, works for me on
latest next.

Best regards,
Gaute

---

From: Matti Eiden <[email-masked]>
Date: Mon, 21 Mar 2011 20:38:31 +0200

Hey folks,

Ruby 1.9.2 doesn't include the "." into LOAD_PATH anymore. Would
anybody like to fix this in the master? The fix is simple, just adding
"./" in front of the paths of the sup-version.rb and sup-files.rb. I
don't see why this would affect earlier Ruby versions in a negative
way, but of course I recommend testing it works before commiting to
the git.

Patch also below.

Regards,
Matti Eiden

diff -aur sup-build/Rakefile sup-build.new/Rakefile
--- sup-build/Rakefile	2011-03-21 19:44:57.000000000 +0200
+++ sup-build.new/Rakefile	2011-03-21 19:52:37.000000000 +0200
@@ -31,8 +31,8 @@

 $:.push "lib"
 require 'rubygems'
-require "sup-files"
-require "sup-version"
+require "./sup-files"
+require "./sup-version"
 require 'rake/gempackagetask.rb'

 spec = Gem::Specification.new do |s|
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel