Subject: [sup-devel] Maildir work

From: Scott Henson <[email-masked]>
Date: Tue, 9 Feb 2010 15:39:54 -0500

I've been working on maildirs cause I wanted to improve how sup works on
maildirs.  This includes some sync-back support for maildirs.  I've had my
head inside the maildir source and I've noticed something.  The maildir
source can easily lose messages because there is nothing guaranteeing that
the souce_id is monotonically increasing.

So I would like to be able to search the sup index to see what source_ids it
knows about and compare that to what is currently in the maildir and create
a list of ids that are new or even ones that are deleted (making sup-sync
--changed a lot quicker).  Is there a way for the source to search the
index, or is what I'm thinking not possible within sup?  Thanks.

-- 
Scott Henson
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Ben Walton <[email-masked]>
Date: Tue, 09 Feb 2010 16:33:26 -0500

Excerpts from Scott Henson's message of Tue Feb 09 15:39:54 -0500 2010:

Hi Scott,

> the souce_id is monotonically increasing.

This was noted some time back, but nothing has been done to correct
it.  William had some thoughts on it, but I don't know if he put hand
to keyboard on it...

I can't help you with the rest of your question as I'm not familiar
with that code at all.

Thanks
-Ben
-- 
Ben Walton
Systems Programmer - CHASS
University of Toronto
C:416.407.5610 | W:416.978.4302

---

From: Mark Alexander <[email-masked]>
Date: Wed, 10 Feb 2010 15:50:42 -0500

On Tue, Feb 9, 2010 at 3:39 PM, Scott Henson <[email-masked]> wrote:
>The maildir source can easily lose messages because there is nothing guaranteeing that
> the source_id is monotonically increasing.

I reported this on Apr 16 2009:

  http://old.nabble.com/Possible-problem-with-maildir-ID-generation-ts23087464.html
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel