Subject: [sup-devel] [PATCH] Bugfix: Don’t display thread participants twice

From: Michael Stapelberg <[email-masked]>
Date: Thu, 07 Oct 2010 19:21:26 +0200

Hi,

Quote from the commit message:
  When a participant of a thread uses different email addresses, but the same
  name, he would be displayed twice in the list:
  Participants:
   • foo <[email-masked]>
   • foo <[email-masked]>
   • bar <[email-masked]>
  would lead to: "foo, bar, foo"

Best regards,
Michael
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Michael Stapelberg <[email-masked]>
Date: Fri, 08 Oct 2010 13:41:55 +0200

Hi Gaute,

Excerpts from Gaute Hope's message of 2010-10-08 12:05:29 +0200:
> What if someone has the same name ? ;) Is it more
> important/likely/intuitive than anyone using two addresses?
If two people have exactly the same name, you would not benefit in seeing that
same name twice, either. Even if one mail of the thread is new and one "Michael
S." is highlighted, you still would not know which one sent the new mail. So,
to avoid confusion about the same name showing up twice, I decided it would be
better to not show duplicates at all.

Best regards,
Michael

---

From: Gaute Hope <[email-masked]>
Date: Fri, 8 Oct 2010 12:05:29 +0200

On Fri, Oct 8, 2010 at 6:17 AM, Rich Lane <[email-masked]> wrote:
> Excerpts from Michael Stapelberg's message of Thu Oct 07 13:21:26 -0400 2010:
>> Hi,
>>
> Applied to master.

- gaute

---

From: Ben Walton <[email-masked]>
Date: Fri, 08 Oct 2010 08:07:32 -0400

> important/likely/intuitive than anyone using two addresses?

A good point, but I'd still rather see a shorter list.  The space is
limited, so squashing duplicate names is fine with me.

HTH.
-Ben
--
Ben Walton
Systems Programmer - CHASS
University of Toronto
C:416.407.5610 | W:416.978.4302

---

From: Gaute Hope <[email-masked]>
Date: Fri, 8 Oct 2010 13:46:28 +0200

> better to not show duplicates at all.

Sure, this isn't really a big issue (for me at least). The duplicates
would be the expected behaviour (for me :)), the benefit being that
you know there is one more guy/emailaccount at work here.

Best regards, Gaute

---

From: Rich Lane <[email-masked]>
Date: Fri, 08 Oct 2010 00:17:41 -0400

Applied to master.