Subject: Re: [sup-devel] [PATCH] flush index on idle

From: Rich Lane <[email-masked]>
Date: Sat, 27 Feb 2010 03:07:37 -0500

Branch idle, merged to next.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Eric Sherman <[email-masked]>
Date: Wed, 20 Jan 2010 23:15:16 -0500

This patch depends on [PATCHv2] idle and unidle updates.
---
 lib/sup/modes/inbox-mode.rb |    4 ++++
 1 files changed, 4 insertions(+), 0 deletions(-)

diff --git a/lib/sup/modes/inbox-mode.rb b/lib/sup/modes/inbox-mode.rb
index 1b8eaed..9e37909 100644
--- a/lib/sup/modes/inbox-mode.rb
+++ b/lib/sup/modes/inbox-mode.rb
@@ -115,6 +115,10 @@ class InboxMode < ThreadIndexMode
     regen_text
   end
 
+  def handle_idle_update sender, idle_since
+    flush_index
+  end
+
   def status
     super + "    #{Index.size} messages in index"
   end
-- 
1.6.6