Subject: [sup-devel] [PATCH] Overwrite line contents before drawing the new contents (instead of filling up the rest)

From: Michael Stapelberg <[email-masked]>
Date: Fri, 07 May 2010 20:55:28 +0200

Hi,

quote from the commit message:

  Overwrite line contents before drawing the new contents (instead of filling
  up the rest)
  
  This fixes display problems of mails with tab characters in it, like
  "foo\n\tbar"

The problem was that \t is one character but will be displayed as multiple
characters, so that the filling started too early and overwrote valid content
of the line (the "bar" is not visible).

Best regards,
Michael
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Thu, 13 May 2010 21:58:47 -0400

> of the line (the "bar" is not visible).

Applied to master.