Subject: [sup-devel] [issue109] Crash when loading all threads (!!)

From: Truxton Fulton <[email-masked]>
Date: Thu, 03 Jun 2010 00:18:23 +0000

New submission from Truxton Fulton <[email-masked]>:

I started sup
There are 127945 messages in index
I pressed L then chose a label that had 10122 messages
sup displayed the first 60 threads
I pressed !! to load all threads
(because I want to apply 'a'rchive to all of them)
after loading 546 threads, sup crashes (log attached).

----------
files: exception-log.txt
keyword: maildir
messages: 244
nosy: trux
priority: bug
ruby_version: 1.8.6
status: unread
sup_version: 0.11
title: Crash when loading all threads (!!)

_________________________________________
Sup issue tracker <[email-masked]>
<http://masanjin.net/sup-bugs/issue109>
_________________________________________

_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Truxton Fulton <[email-masked]>
Date: Thu, 03 Jun 2010 01:27:34 -0700

Hi sup developers!

I've narrowed down the crash to the presence of 2 particular mails.
I can reproduce the crash by creating a brand new sup config
for a maildir containing only these 2 messages.  When sup starts
up it gets the "wrong id called on nil" crash.  It seems that
either message by itself is fine, but the combination of the
two messages causes the problem.

You can download these mails from my web server :

  http://www.truxton.com/bad2.tar.gz

Thanks,

-Truxton
--