Subject: Re: [sup-devel] [PATCH] Make sup-tweak-labels work as advertised with no sources listed

From: William Morgan <[email-masked]>
Date: Thu, 31 Dec 2009 11:08:27 -0800

Applied to master, thanks!
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Tero Tilus <[email-masked]>
Date: Wed, 30 Dec 2009 05:09:19 +0200

Signed-off-by: Tero Tilus <[email-masked]>
---

It is checked later (line 68) on if there were any sources to work
with.  This 'if ARGV.empty?' just prevents using sup-tweak-labels for
all sources.

 bin/sup-tweak-labels |    1 -
 1 files changed, 0 insertions(+), 1 deletions(-)

diff --git a/bin/sup-tweak-labels b/bin/sup-tweak-labels
index 90f6a57..9bb97b2 100755
--- a/bin/sup-tweak-labels
+++ b/bin/sup-tweak-labels
@@ -58,7 +58,6 @@ add_labels = opts[:add].to_set_of_symbols ","
 remove_labels = opts[:remove].to_set_of_symbols ","
 
 Trollop::die "nothing to do: no labels to add or remove" if add_labels.empty? && remove_labels.empty?
-Trollop::die "no sources specified" if ARGV.empty?
 
 Redwood::start
 index = Redwood::Index.init
-- 
Tero Tilus ## 050 3635 235 ## http://tero.tilus.net/
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel