Subject: Re: [sup-devel] heliotrope: Crash with empty message.recipients

From: Gregor Hoffleit <[email-masked]>
Date: Wed, 18 May 2011 17:47:03 +0200

* William Morgan <[email-masked]> [Mi Mai 18 16:52:59 +0200 2011]
> Reformatted excerpts from Gregor Hoffleit's message of 2011-05-16:
> > The problem with empty recipient strings is still there, I'm afraid.
> > Tested today, with current heliotrope from GIT.
> 
> Rats. Can you please add an issue to the heliotrope github issue tracker
> so that I don't forget about this?

Done. https://github.com/wmorgan/heliotrope/issues/1
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Wed, 18 May 2011 14:52:59 +0000

-- 
William <[email-masked]>

---

From: Gregor Hoffleit <[email-masked]>
Date: Mon, 16 May 2011 17:56:36 +0200

* William Morgan <[email-masked]> [Di Mai 10 19:45:49 +0200 2011]
> Reformatted excerpts from Gregor Hoffleit's message of 2011-04-20:
> > 
> >     To: , [email-masked]
> > 
> > This code in line 482 of lib/heliotrope/index.rb will fail work if any
> > recipient is empty:
> > 
> >     message.recipients.map { |x| x.indexable_text }.join(" ").downcase
> 
> Sorry for the lengthy wait. I believe this has been fixed. Please let me
> know if you still encounter this problem!

Regards,
    Gregor

---

From: William Morgan <[email-masked]>
Date: Tue, 10 May 2011 17:45:49 +0000