Subject: [sup-devel] [PATCH] Bugfix: mime_encode: Encode _ as =5F instead of =96

From: Michael Stapelberg <[email-masked]>
Date: Tue, 26 Oct 2010 00:13:46 +0200

Hi,

quote from the commit message:

    This line of code was introduced in 0d45aa38, probably by mistake. The ASCII
    code in decimal for '_' (underscore) is 95 (the code says 96, but probably
    another mistake), but as mime encoding is hexadecimal, we need =5F instead.
    
    An example of this encoding problem can be seen in one of my earlier patches
    with message-id <[email-masked]>.

Best regards,
Michael
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Thu, 04 Nov 2010 12:04:23 -0400

Applied to master.