Subject: Re: [sup-devel] [PATCH] Allow toggle on Source.usual and Source.archived

From: Rich Lane <[email-masked]>
Date: Wed, 02 Jun 2010 23:58:49 -0400

Applied to master.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Ben Walton <[email-masked]>
Date: Sat, 15 May 2010 14:45:21 -0400

Allow sources to be more malleable by allowing for the modification of
the usual and archived flags.  This is a first step toward patterned
(meta) sources.  Initially, the patterning will be handled by one of
the poll hooks, which will use the usual toggle when a 'new' source is
added.  Later on, this may be handled internally for sources with a
meta = true attribute (or something similar).

Signed-off-by: Ben Walton <[email-masked]>
---
 lib/sup/source.rb |    3 ++-
 1 files changed, 2 insertions(+), 1 deletions(-)

diff --git a/lib/sup/source.rb b/lib/sup/source.rb
index 6fe7bfb..2f2e5df 100644
--- a/lib/sup/source.rb
+++ b/lib/sup/source.rb
@@ -63,7 +63,8 @@ class Source
   ##
   ## dirty? means cur_offset has changed, so the source info needs to
   ## be re-saved to sources.yaml.
-  bool_reader :usual, :archived, :dirty
+  bool_reader :dirty
+  bool_accessor :usual, :archived
   attr_reader :uri, :cur_offset
   attr_accessor :id
 
-- 
1.7.0