Subject: Re: [sup-talk] sup: Fix for an UndefinedMethodError

From: Gaute Hope <[email-masked]>
Date: Sun, 14 Apr 2013 00:17:32 +0200

On la. 13. april 2013 kl. 22.48 +0200, Jonathan Lassoff wrote:
> Maybe William can help out?
> https://twitter.com/wm/status/323175493367119873

That would be the best ;)

But I still think we need to get rid of the deprecated and abandoned 
stuff.

- gaute

---

From: Eric Weikl <[email-masked]>
Date: Thu, 15 Aug 2013 15:22:14 +0200

Hi fellow sup users,

the maildir-sync branch has been hanging around for quite a while. Since
sup 0.14.0 is out now, we could consider merging it into the developer
branch. I've been using the branch continuously and haven't encountered
any problems so far.

Has anyone else tried the branch, or is willing to do so? It would be
great to have some more opinions on it.

Gaute created a corresponding pull request here:
https://github.com/sup-heliotrope/sup/pull/126

Cheers,
Eric

On 04/16/2013 22:30:26, Eric Weikl wrote:
> Hi everyone,
> 
> I created a new branch with all the commits from Damien Leone and
> Edward Yang related to maildir syncback and put it here:
> 
> https://github.com/sup-heliotrope/sup/tree/maildir-sync
> 
> I skipped some advanced stuff like Edward's inotify support for now. We
> can add that later.
> 
> I performed some basic testing, but it would be great if some more
> people could give it a try. There's some documentation in the wiki:
> 
> https://github.com/sup-heliotrope/sup/wiki/Maildir-Syncback
> 
> Cheers,
> Eric
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Jonathan Lassoff <[email-masked]>
Date: Sat, 13 Apr 2013 12:19:17 -0700

On Sat, Apr 13, 2013 at 10:37 AM, Gaute Hope <[email-masked]> wrote:
> If we go sup2 I would suggest the following plan:
>
> - Release the best we can get with the current code for 1.9.3 as a last
> community release of sup-0.12, say.. sup-0.13.
>
> For sup2:
> - Fork a new repo: sup2
> - Go for Mail in stead of RMail (index breakage)
> - Go for only Psych (config breakage), requires psych gem in 1.8
> - Integrate the IMAP / label sync back stuff (personally this is what I
> miss the most)
> - Go for ruby 2.0.0 and maybe 1.8
> - Get rid of all dependencies that are abandoned or deprecated (ncurses
> gem..)

And target ncursesw?

> - Try to do tests on most stuff for different encodings
> - Try to get UTF-8 / encoding right
> - Move all the rest of the infrastructure to something the project is in
> control of
>
> Would be very nice:
> - Index migration
> - Config migration
>
> For the web page (eventually):
> - note about the original project
> - note about the last sup-0.13 release
> - wiki and project page for sup2
>
> This plan more or less holds whether we go sup2 or not, but I think it
> is easier to get rid of the hopeless dependencies.

I agree that it's worth it to drop unmaintained dependencies and just
fix what breaks.
It would be unfortunate to have to fork the project and make a
different name. I wonder if Morgan has lost interest or is just busy
with other things.

Cheers,
jof
> @sup-devel readers: discussion is currently at sup-talk, please send any
> responses there.
>
> Regards, Gaute
>
> On 13. april 2013 19:14, Gaute Hope wrote:
>>
>>
>> On 13. april 2013 18:35, Jonathan Lassoff wrote:
>>> On Sat, Apr 13, 2013 at 6:17 AM, Gaute Hope <[email-masked]> wrote:
>>>> On la. 13. april 2013 kl. 12.09 +0200, Jonathan Lassoff wrote:
>>>>> On Sat, Apr 13, 2013 at 2:16 AM, Gaute Hope <[email-masked]> wrote:
>>>>>> Hi,
>>>>>>
>>>>>> Jonathan: I put your commit into a pull request at:
>>>>>> - https://github.com/sup-heliotrope/sup/pull/19
>>>>>>
>>>>>> Also, re-branding and updating to web-references:
>>>>>> - https://github.com/sup-heliotrope/sup/pull/20
>>>>>>
>>>>>> any comments on this? You can see the changes I made. I have absolutely
>>>>>> no intentions of stepping on any toes, but this is a suggestion.
>>>>>
>>>>> No, thank you very much! That looks great!
>>>>>
>>>>>> It is a pity that the official home page and probably first search
>>>>>> results direct to the abandoned home and gem of sup.
>>>>>
>>>>> It is too bad. Hopefully William could hand off access or at least
>>>>> push updates somehow.
>>>>>
>>>>> If not, maybe we could stand up another domain pointing to github pages?
>>>>> Looks like supmua.org and supm.ua are available. :p
>>>>>
>>>>> --j
>>>>
>>>> Yeah.. I think some web page is pretty essential, perhaps just the
>>>> standard github-pages domain for a start. Anyone feel up for the task,
>>>> I'd be happy to add you to the github-organization.
>>>
>>> Agreed. I snagged supmua.org for a year, and have it pointing at
>>> sup-heliotrope.github.io for pages.
>>>
>>> Stick me on the org, and I'll see about getting a simple site started.
>>
>> Nice. You're on.
>>
>> Cheers, Gaute
>>

---

From: Jonathan Lassoff <[email-masked]>
Date: Sat, 13 Apr 2013 13:48:55 -0700

---

From: Gaute Hope <[email-masked]>
Date: Sat, 13 Apr 2013 19:37:01 +0200

For sup2:
- Fork a new repo: sup2

Would be very nice:
- Index migration
- Config migration

Regards, Gaute