Subject: Re: [sup-devel] [issue47] utf-8 regression: search&inbox views has garbled utf-8

From: Tarko Tikan <[email-masked]>
Date: Tue, 02 Mar 2010 16:47:42 +0200

hey,

I hit the same bug after upgrade and I've logged my findings (and workarounds) to http://masanjin.net/sup-bugs/issue47

I think the snippet issue might be because http://gitorious.org/sup/mainline/commit/f26d4052c5bf5f327239e8555f4167a2cfa0e00f - snippet might already be wrongly converted in index or needs conversion before display.

-- 
tarko
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: anonymous <[email-masked]>
Date: Sun, 24 Jan 2010 17:07:08 +0000

New submission from anonymous:

Hi!

I upgraded to 0.10 by doing git pull && git checkout origin/release-0.10.

After a friendly nag about upgrading to Xapian, sup started nicely. But: In all
search-results and in the inbox, any non-ascii utf-8 characters are displayed in
a garbled format, for example: "Autosøk" becomes "Autos\xc3\xb8k".

Searching for "autosøk" works as expected, and what's even stranger is that
after viewing one of these threads, and then going back to the search buffer, it
will show the utf-8 correctly for that single thread.

Something is not quite right here...

----------
messages: 112
nosy: anonymous
priority: bug
ruby_version: 1.8.7
status: unread
sup_version: 0.10
title: utf-8 regression: search&inbox views has garbled utf-8

_________________________________________
Sup issue tracker <[email-masked]>
<http://masanjin.net/sup-bugs/issue47>
_________________________________________
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel