Subject: [sup-devel] [PATCH] sup-sync: only show message id of deleted messages in verbose mode

From: Sascha Silbe <[email-masked]>
Date: Tue, 18 Jan 2011 19:25:28 +0100

We show message ids for added messages in verbose mode only, so we should do
the same for deleted messages.

Signed-off-by: Sascha Silbe <[email-masked]>
---
 bin/sup-sync |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/bin/sup-sync b/bin/sup-sync
index 1d1fda1..b4d5cba 100755
--- a/bin/sup-sync
+++ b/bin/sup-sync
@@ -124,7 +124,7 @@ begin
       num_scanned += 1
       if action == :delete
         num_deleted += 1
-        puts "Deleting #{m.id}"
+        puts "Deleting #{m.id}" if opts[:verbose]
       elsif action == :add
         seen[m.id] = true
 
-- 
1.7.2.3

_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Tue, 18 Jan 2011 22:40:27 -0500

Applied to master.