Subject: Re: [sup-devel] [PATCH] implement const_missing for Index

From: William Morgan <[email-masked]>
Date: Tue, 05 Jan 2010 13:50:18 -0800

Reformatted excerpts from Rich Lane's message of 2010-01-04:
> Otherwise, constant references to LockError and ParseError will fail.

Applied to ferret-deprecation and remerged into next. Thanks!
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Mon, 04 Jan 2010 14:48:13 -0500

Excerpts from William Morgan's message of 2010-01-04 14:43:58 -0500:
> > This should be added to the ruby-1.9-encoding branch.
> 
> Not to ferret-deprecation?

Oh, right, sorry. Airports are messing with my brain.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Mon, 04 Jan 2010 11:43:58 -0800

---

From: Rich Lane <[email-masked]>
Date: Mon, 4 Jan 2010 11:35:17 -0800

---

 lib/sup/index.rb |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)

diff --git a/lib/sup/index.rb b/lib/sup/index.rb
index f02c96b..8a4b8f2 100644
--- a/lib/sup/index.rb
+++ b/lib/sup/index.rb
@@ -234,6 +234,7 @@ class Index
 
   def self.instance; @obj end
   def self.method_missing m, *a, &b; @obj.send(m, *a, &b) end
+  def self.const_missing x; @obj.class.const_get(x) end
 end
 
 end
-- 
1.6.3.3