Subject: [sup-devel] [PATCH] fix up options for sup-sync-back, tweak-labels

From: Anthony Martinez <[email-masked]>
Date: Tue, 5 Jan 2010 10:20:24 -0700

These two violate the convention of the other scripts inside bin/ by
using a local variable for their Trollop results.
---
 bin/sup-sync-back    |    2 +-
 bin/sup-tweak-labels |    2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/bin/sup-sync-back b/bin/sup-sync-back
index 19e6230..40c1e1c 100755
--- a/bin/sup-sync-back
+++ b/bin/sup-sync-back
@@ -66,7 +66,7 @@ EOS
 end
 
 Redwood::start
-index = Redwood::Index.init $opts[:index]
+index = Redwood::Index.init opts[:index]
 index.lock_interactively or exit
 
 deleted_fp, spam_fp = nil
diff --git a/bin/sup-tweak-labels b/bin/sup-tweak-labels
index f603502..bf36a32 100755
--- a/bin/sup-tweak-labels
+++ b/bin/sup-tweak-labels
@@ -61,7 +61,7 @@ remove_labels = opts[:remove].to_set_of_symbols ","
 Trollop::die "nothing to do: no labels to add or remove" if add_labels.empty? && remove_labels.empty?
 
 Redwood::start
-index = Redwood::Index.init $opts[:index]
+index = Redwood::Index.init opts[:index]
 index.lock_interactively or exit
 begin
   index.load
-- 
1.6.5

_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Tue, 05 Jan 2010 13:58:35 -0800

> using a local variable for their Trollop results.

I actually prefer the non-global-variable version, so maybe should say
the other scripts violate the convention. :)

Branch ferret-deprecation, remerged into next. Thanks!
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel