Subject: Re: [sup-devel] [PATCH] dont check thread-index-mode dirtiness on every keypress

From: Rich Lane <[email-masked]>
Date: Sat, 27 Feb 2010 02:48:00 -0500

Applied to master.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Mon, 01 Mar 2010 09:58:59 -0500

Reformatted excerpts from Rich Lane's message of 2010-01-23:
> Now that changes are instantly written to the index it's unnecessary
> to put the "modified" message in the status line. Removing this cuts
> the time for a simple action like moving the cursor by 75% or more,
> depending on the number of messages loaded.

This is a really nice change.
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Sat, 23 Jan 2010 19:17:17 -0800

Now that changes are instantly written to the index it's unnecessary to put the
"modified" message in the status line. Removing this cuts the time for a simple
action like moving the cursor by 75% or more, depending on the number of
messages loaded.
---
 lib/sup/modes/thread-index-mode.rb |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/lib/sup/modes/thread-index-mode.rb b/lib/sup/modes/thread-index-mode.rb
index a6bb2b9..71c8f44 100644
--- a/lib/sup/modes/thread-index-mode.rb
+++ b/lib/sup/modes/thread-index-mode.rb
@@ -651,7 +651,7 @@ EOS
     if (l = lines) == 0
       "line 0 of 0"
     else
-      "line #{curpos + 1} of #{l} #{dirty? ? '*modified*' : ''}"
+      "line #{curpos + 1} of #{l}"
     end
   end
 
-- 
1.6.3.3