Subject: Re: [sup-devel] [PATCHv2] [issue44] cursor sticks to thread

From: William Morgan <[email-masked]>
Date: Wed, 20 Jan 2010 11:28:23 -0500

Reformatted excerpts from Eric Sherman's message of 2010-01-12:
> This is much more concise version, using set_cursor_pos instead of 
> cursor_up and cursor_down.

Applied directly to master. Thanks!
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Eric Sherman <[email-masked]>
Date: Tue, 12 Jan 2010 15:36:13 -0500

The cursor will track the thread it is on when that thread is moved up
or down on the screen as threads are added or removed from the view.
---
 lib/sup/modes/thread-index-mode.rb |    2 ++
 1 files changed, 2 insertions(+), 0 deletions(-)

diff --git a/lib/sup/modes/thread-index-mode.rb b/lib/sup/modes/thread-index-mode.rb
index a5bd344..40f622b 100644
--- a/lib/sup/modes/thread-index-mode.rb
+++ b/lib/sup/modes/thread-index-mode.rb
@@ -219,12 +219,14 @@ EOS
   end
 
   def update
+    old_cursor_thread = cursor_thread
     @mutex.synchronize do
       ## let's see you do THIS in python
       @threads = @ts.threads.select { |t| !@hidden_threads[t] }.sort_by { |t| [t.date, t.first.id] }.reverse
       @size_widgets = @threads.map { |t| size_widget_for_thread t }
       @size_widget_width = @size_widgets.max_of { |w| w.display_length }
     end
+    set_cursor_pos @threads.index(old_cursor_thread)||curpos
 
     regen_text
   end
-- 
1.6.6