Subject: [sup-devel] heliotrope: new version of whistlepig

From: Nicolas Pouillard <[email-masked]>
Date: Fri, 13 Apr 2012 15:48:08 +0200

Excerpts from Michael Stapelberg's message of 2012-04-13 14:59:04 +0200:
> Hi William,
> 
> you released a new version of whistlepig. Its index format is incompatible with
> the old version of whistlepig.

Ouch.

> Can you please instruct us on how to migrate from whistlepig 0.7 to 0.11
> without losing any data and preserving the exact inbox state?

+1

Have a command to dump the state information would be very nice as well.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Fri, 13 Apr 2012 14:03:40 -0700

> without losing any data and preserving the exact inbox state?

Sorry about that. I meant to send a notice to this list but forgot.

I have been working hard on Whistlepig recently, fixing some performance
bugs and adding features. I will probably release another breaking index
change, or two, within the next few months.

You can rebuild your index by killing your server and running:

  ruby -Ilib bin/heliotrope-reindex

And then following the instructions about renaming the directory.

Let me know if you have any problems with that.

-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Michael Stapelberg <[email-masked]>
Date: Fri, 13 Apr 2012 14:59:04 +0200

Hi William,

Best regards,
Michael