Subject: Re: [sup-devel] mail gem no longer needs activesupport [was: sup-server revisited]

From: William Morgan <[email-masked]>
Date: Tue, 10 May 2011 12:06:08 +0000

Reformatted excerpts from Hamish's message of 2011-05-08:
> Might be a bit late, but I've just noticed that they're taking the
> activesupport dependency out, as of mail 2.3.0

Good to know. I won't switch Heliotrope over just for the heck of it,
but if I encounter insurmountable problems with RubyMail we'll at least
have a backup plan.
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Hamish <[email-masked]>
Date: Sun, 08 May 2011 17:36:22 +0100

Excerpts from William Morgan's message of Tue Feb 22 21:29:07 +0000 2011:
> Reformatted excerpts from Tero Tilus's message of 2011-02-22:
> > Would it be time to go for https://github.com/mikel/mail now?  It would be
> > supported and actively developed and I really like the API.  As a
> > downside, depending on activesupport pulls in a whole a lot of fluff and
> > using treetop may suggest that parsing might hog a little more cpu and
> > memory than is absolutely necessary.
> 
> I looked at it, but the dependency on activesupport is a dealbreaker for me.
> There's no way I would pull that pile of Rails shit into Sup.

http://rubygems.org/gems/mail/versions/2.3.0 - no activesupport

On github, the gemspec no longer refers to it:

https://github.com/mikel/mail/blob/master/mail.gemspec

though the Gemfile still does ... I think this is an oversight.

https://github.com/mikel/mail/blob/master/Gemfile

A couple of commits doing the work:

https://github.com/mikel/mail/commit/6eb4c44a15eb1707dde60959e85e5c536ef136e2
https://github.com/mikel/mail/commit/8bea8ede624e81fb4704e66097a1c8cf35f8de8d

> RMail is not great and I don't like using it, but it really is the best
> thing I've found so far. I think I have whipped it into shape pretty well in
> heliotrope.
> 
> > Who would give us bindings to GMime and wrap it inside Mail API...
> 
> I would use GMime bindings in a heartbeat.

Hamish