Subject: [sup-devel] [PATCH] xapian: respect :skip_killed in each_message_in_thread_for

From: Rich Lane <[email-masked]>
Date: Fri, 1 Jan 2010 13:44:34 -0800

---
 lib/sup/xapian_index.rb |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/lib/sup/xapian_index.rb b/lib/sup/xapian_index.rb
index cebb148..955ec8f 100644
--- a/lib/sup/xapian_index.rb
+++ b/lib/sup/xapian_index.rb
@@ -127,7 +127,7 @@ EOS
     while not queue.empty?
       thread_id = queue.pop
       next if seen_threads.member? thread_id
-      return false if thread_killed? thread_id
+      return false if opts[:skip_killed] && thread_killed?(thread_id)
       seen_threads << thread_id
       docs = term_docids(mkterm(:thread, thread_id)).map { |x| @xapian.document x }
       docs.each do |doc|
-- 
1.6.3.3

_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Sun, 03 Jan 2010 07:00:03 -0800

Applied directly to master. Thanks!

-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel