Subject: Re: [sup-devel] [PATCH] Return nothing between if end index is not found.

From: Michael Stapelberg <[email-masked]>
Date: Wed, 18 Aug 2010 00:46:32 +0200

Hi Edward,

Excerpts from Edward Z. Yang's message of 2010-08-16 21:55:32 +0200:
> Fascinatingly enough, I cannot find it in either my inbox or my spam filter. (Dun dun dun.)
> Maybe you should send it as an attachment.
Interesting. I gzipped it (to make sure it does not get touched in any way on
its way to you) and attached it to this mail.

Best regards,
Michael
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: "Edward Z. Yang" <[email-masked]>
Date: Mon, 16 Aug 2010 15:55:32 -0400

Excerpts from Michael Stapelberg's message of Mon Aug 16 13:22:26 -0400 2010:
> Hi Edward,
> 
> Excerpts from Edward Z. Yang's message of 2010-08-16 03:40:33 +0200:
> > What's the subject line?
> The subject line is:
> "Fwd: Fwd: Re: [RaumZeitLabor] Portalroboter kostenlos bei Selbstabholung - Interesse?"

Edward

---

From: Michael Stapelberg <[email-masked]>
Date: Mon, 16 Aug 2010 03:19:35 +0200

Hi Edward,

Excerpts from Edward Z. Yang's message of 2010-08-16 01:30:46 +0200:
> I was hoping to get a copy of the email that broke for you, but it never
> found its way to me. Perhaps you could resend it?
Just did so. Message-ID is <[email-masked]>.

Best regards,
Michael

---

From: "Edward Z. Yang" <[email-masked]>
Date: Sun, 18 Jul 2010 13:53:39 -0400

This patch fixed Nil error that occurred when I had a GPG signed
mail with a starting marker but no ending marker.

>From 22d12ffe7caa0d11c91876e2c8c7806854d0b3ab Mon Sep 17 00:00:00 2001
From: Edward Z. Yang <[email-masked]>
Date: Sun, 18 Jul 2010 03:38:52 -0400
Subject: [PATCH] Return nothing between if end index is not found.

Signed-off-by: Edward Z. Yang <[email-masked]>
---
 lib/sup/util.rb |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)

diff --git a/lib/sup/util.rb b/lib/sup/util.rb
index d19caca..dad479f 100644
--- a/lib/sup/util.rb
+++ b/lib/sup/util.rb
@@ -479,6 +479,7 @@ module Enumerable
 
   ## returns all the entries which are equal to startline up to endline
   def between startline, endline
+    return [] if not index(endline)
     select { |l| true if l == startline .. l == endline }
   end
 end
-- 
1.7.0.4
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Alvaro Herrera <[email-masked]>
Date: Mon, 16 Aug 2010 12:27:15 -0400

Excerpts from Edward Z. Yang's message of dom ago 15 21:40:33 -0400 2010:
> Excerpts from Michael Stapelberg's message of Sun Aug 15 21:19:35 -0400 2010:

So it kinda sucks that one can't search for a message by Message-Id, eh?.
I have a lot of need for that functionality, since the whole PostgreSQL
patch management workflow is based on them.

-- 
Álvaro Herrera <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Michael Stapelberg <[email-masked]>
Date: Tue, 20 Jul 2010 22:09:39 +0200

Hi,

Excerpts from Michael Stapelberg's message of 2010-07-20 00:50:37 +0200:
> Thanks for the patch, I can confirm it working and necessary.
I was wrong. I just opened an email and it was no longer verified (it is
GPG-signed). I will post an updated patch soon.

Best regards,
Michael

---

From: "Edward Z. Yang" <[email-masked]>
Date: Sun, 15 Aug 2010 19:30:46 -0400

> GPG-signed). I will post an updated patch soon.

Hi Michael,

Thanks,
Edward

---

From: "Edward Z. Yang" <[email-masked]>
Date: Thu, 09 Sep 2010 12:55:25 -0400

> its way to you) and attached it to this mail.

I finally got around to looking at your message, and as expected, it appears
that there is no trailing END PGP MESSAGE block, which is why my patch breaks
your behavior (it claims there is no valid PGP block.)

Regardless of what the PGP standard says, I suppose it's good practice
to be liberal in what we accept.  So the correct change might be to
keep the existing semantics of between (documenting carefully what happens
if the ending line is not present) and then fixing the code that relies
on the bogus invariant.

This also resolves Kevin Riggle’s issue.

Cheers,
Edward

---

From: "Edward Z. Yang" <[email-masked]>
Date: Sun, 15 Aug 2010 21:40:33 -0400

What's the subject line?

Edward

---

From: Kevin Riggle <[email-masked]>
Date: Thu, 09 Sep 2010 15:08:45 -0400

> its way to you) and attached it to this mail.
These days GMail, at least, will look inside your gzipped attachments and will 
block attachments containing binaries.  Now, if you'd PGP-encrypted it.....

- Kevin
--
Kevin Riggle ([email-masked]) 
http://free-dissociation.com
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Michael Stapelberg <[email-masked]>
Date: Tue, 20 Jul 2010 00:50:37 +0200

Hi Edward,

Best regards,
Michael

---

From: Michael Stapelberg <[email-masked]>
Date: Mon, 16 Aug 2010 19:22:26 +0200

Hi Edward,

The subject line is:

Best regards,
Michael