Subject: [sup-devel] [Heliotrope] search for cyrillic terms does not work

From: William Morgan <[email-masked]>
Date: Fri, 24 Feb 2012 22:42:57 -0800

Excerpts from Serge Z's message of 2012-02-23 21:43:18 -0800:
> Can you please suppose why that could happen or offer a simple
> workaround?  This issue is the only one which stops me from migrating
> to Heliotrope/Turnsole.

I'll have to look into it. Super-ascii search was definitely working at
some point, so I'm not sure why there was a regression. You can help by
trying to see whether the problem is in whistlepig or in heliotrope,
e.g. by adding and querying Cyrillic documents in a whistlepig index of
your own construction.

-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Mon, 05 Mar 2012 14:57:34 -0800

Excerpts from Serge Z's message of 2012-02-29 02:44:13 -0800:
> Does whistlepig have any tool for manual managing its indexes?
> Or do I have to code in either ruby or C to do that?

Yeah, if you check it out separately and build it, you can run
something like:

  whistlepig$ make dump
  whistlepig$ ./dump <heliotrope store dir>/index/whistlepig|less

And then if you search for some Cyrillic text, that should at least
tell you the tokenization in the index.
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Serge Z <[email-masked]>
Date: Fri, 24 Feb 2012 09:43:18 +0400

Hi!
I've submitted issue #36 at github.com on this problem.

> Search for cyrillic terms does not work both in web-interface and turnsole.
> 
> The search term is present in utf-8 and windows-1251 encodings in different mails.
> My system encoding is utf-8.
> 
> Ruby 1.9
> 
> Please inform if this is not an issue with ruby 1.8 or any other environment

Can you please suppose why that could happen or offer a simple workaround?
This issue is the only one which stops me from migrating to Heliotrope/Turnsole.

I'd not got this problem with sup.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Serge Z <[email-masked]>
Date: Wed, 29 Feb 2012 14:44:13 +0400

Quoting William Morgan (2012-02-25 10:42:57)