Subject: [sup-devel] [PATCH] Bugfix: Create dynamically growing fields (long filenames are now supported)

From: Michael Stapelberg <[email-masked]>
Date: Mon, 15 Feb 2010 23:13:00 +0100

Hi,

the attached patch modifies textfield.rb to create a dynamically growable field
instead of one with a fixed size. The text field can now hold a dynamic amount
of characters which is often necessary if you have long file names.

How to reproduce the bug:
1) mkdir -p /tmp/very/long-folder-name-foo-bar-baz/longer-than-one-line-foo-bar-bleh-bleh/maw-maw-maw-maw-maw-maw-maw-maw-maw-maw-maw
2) echo foo > /tmp/very/long-folder-name-foo-bar-baz/longer-than-one-line-foo-bar-bleh-bleh/maw-maw-maw-maw-maw-maw-maw-maw-maw-maw-maw/foo.txt
3) create a new message in sup and try to add the new file as an attachment

Please merge this one for the next release.

Best regards,
Michael
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Michael Stapelberg <[email-masked]>
Date: Sat, 27 Feb 2010 13:45:17 +0100

Hi Rich,

Excerpts from Rich Lane's message of Sa Feb 27 09:18:17 +0100 2010:
> Is this still necessary on latest master?
I just saw that you already posted and merged a patch which does the same,
so it should not be necessary.

Best regards,
Michael

---

From: Rich Lane <[email-masked]>
Date: Sat, 27 Feb 2010 03:18:17 -0500