Subject: Re: [sup-devel] [PATCH] implement String#each on Ruby 1.9 for lockfile

From: William Morgan <[email-masked]>
Date: Tue, 05 Jan 2010 13:34:10 -0800

So lame. Applied to master. Thanks!
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Mon, 4 Jan 2010 11:34:31 -0800

---
 lib/sup/util.rb |    6 ++++++
 1 files changed, 6 insertions(+), 0 deletions(-)

diff --git a/lib/sup/util.rb b/lib/sup/util.rb
index 206c18a..2d3a2ad 100644
--- a/lib/sup/util.rb
+++ b/lib/sup/util.rb
@@ -290,6 +290,12 @@ class String
     end
   end
 
+  unless method_defined? :each
+    def each &b
+      each_line &b
+    end
+  end
+
   ## takes a list of words, and returns an array of symbols.  typically used in
   ## Sup for translating Ferret's representation of a list of labels (a string)
   ## to an array of label symbols.
-- 
1.6.3.3