Subject: Re: [sup-devel] call for new maintainers

From: Hamish D <[email-masked]>
Date: Wed, 26 Jan 2011 23:44:28 +0000

> Reformatted excerpts from Ben Walton's message of 2011-01-26:
>> I think it would be nicer to still see all patches posted to the list
>> first, regardless of committer rights.  It's nice to see what people
>> are doing and be able to comment on proposed changes.
>
> Yeah, that would be good, and I hereby encourage that kind of behavior.
> I just don't want the "waiting for William to get around to it" to be
> the blocking factor like it's always been.

Sounds good to me. I've just signed up to gitorious with user name foobacca.

Hamish
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Mon, 07 Mar 2011 18:27:38 +0000

Reformatted excerpts from Sascha Silbe's message of 2011-03-04:
> And of course forgot to mention the account name: silbe.

Added.
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Fri, 28 Jan 2011 01:20:50 -0500

Reformatted excerpts from Tero Tilus's message of 2011-01-27:
> I'm http://gitorious.org/~terotil

Added! And now I can ignore all your outstanding patch requests. :)

> > All I ask is that you divide things into nice topic branches and
> > merge them into next but not master.
> 
> Do you prefer basing feature branches to master or next?

Base them off of master, please. If they're based off of next, I can't
merge them into master without also merging all of next.

> Should we prefix feature branch names to keep `git branch` more
> readable?  They could be topic-* or feature-* or alike.

I don't think that's necessary. The only two integration branches are
master and next (and the release-* branches, I suppose). When I merge
things into master I will delete the remote branches as well, so we
shouldn't end up with a big mess.
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Wed, 26 Jan 2011 10:18:59 -0500

Reformatted excerpts from Michael Stapelberg's message of 2011-01-24:
> I don’t have enough time to be the only person doing this, but I do
> offer my help on reviewing/merging patches. Maybe having more than one
> guy with commit access turns out to be a good thing?

Yeah, maybe that's the right idea.

So let's try this. Michael, Tero, Sascha, Edward, and everyone else
who's had code make it into Sup successfully... if you send me your
Gitorious usernames, I will add you to the Sup group and you will have
push access. Then you can bypass the list mailing list for patches
entirely, which will save me a lot of work.

All I ask is that you divide things into nice topic branches and merge
them into next but not master. I'll merge individual branches into
master when prepping for a release.
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: "Wael M. Nasreddine" <[email-masked]>
Date: Tue, 25 Jan 2011 15:19:10 +0100

Hello,

How much work you estimate per week?

I'm familiar with Ruby and Git, but I'm not very familiar with the code of
SUP itself as I haven't read it entirely yet.. I would gladly help sup but I
need to know first how much work to expect..

Regards,
Wael Nasreddine

On Mon, Jan 24, 2011 at 19:40, William Morgan <[email-masked]>wrote:

> I said this in another thread on sup-devel, but I thought I'd give it a
> broader audience.
>
> Rich is stepping down as maintainer due to lack of time (but will still
> be around as a contributor). I personally have a little more time
> nowadays than I did before. But I would rather spend it working on
> features, including possible a new index backend.
>
> So, anyone who would be interested in the maintainership busywork of
> collecting patches from sup-devel, making branches, and pushing
> releases, please let me know. You must be familiar with git, Ruby and,
> of course, Sup. I can provide a brief guide of how this all works.
>
> In exchange, you will have access to the secret Sup maintainer meetings
> that take place in the smoky backrooms of various San Francisco bars.
>
> If multiple people are interested, we can set up a rotation so that no
> one is stuck with it forever.
>
> If no one responds, I will continue to be your (not very responsive)
> maintainer.
> --
> sup-talk mailing list
> [email-masked]
> http://rubyforge.org/mailman/listinfo/sup-talk
>

-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Waêl Nasreddine
TechnoGate www.technogate.fr
mobile :  06.32.94.70.13
agence : 09.70.444.236
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
_______________________________________________
sup-talk mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-talk

---

From: Ben Walton <[email-masked]>
Date: Wed, 26 Jan 2011 11:10:53 -0500

Excerpts from William Morgan's message of Wed Jan 26 10:18:59 -0500 2011:

Hi William,

> Gitorious usernames, I will add you to the Sup group and you will
> have push access. Then you can bypass the list mailing list for
> patches entirely, which will save me a lot of work.

This doesn't preclude pushing to a topic branch as well, but it's
easier to comment on something if you don't need to track all of those
branches too...

Just a thought.

I'm bwalton on gitorious, btw.

Thanks
-Ben
--
Ben Walton
Systems Programmer - CHASS
University of Toronto
C:416.407.5610 | W:416.978.4302

---

From: William Morgan <[email-masked]>
Date: Mon, 07 Mar 2011 18:27:20 +0000

Reformatted excerpts from Damien Leone's message of 2011-03-04:
> My gitorious login is dleone.

Added.

---

From: Damien Leone <[email-masked]>
Date: Fri, 04 Mar 2011 10:05:52 +0100

Hello,

Could I have an access so I can push the finished maildir-sync branch
as well as some other patches?

Thanks,

-- 
Damien Leone <[email-masked]>

Web: http://dleone.fensalir.fr/
GPG: 0x82EB4DDF
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Wed, 26 Jan 2011 13:13:40 -0500

Added.

---

From: William Morgan <[email-masked]>
Date: Mon, 24 Jan 2011 13:40:49 -0500

---

From: Michael Stapelberg <[email-masked]>
Date: Mon, 24 Jan 2011 20:20:18 +0100

Hi William,

> of course, Sup. I can provide a brief guide of how this all works.
I don’t have enough time to be the only person doing this, but I do offer my
help on reviewing/merging patches. Maybe having more than one guy with commit
access turns out to be a good thing?

Best regards,
Michael

---

From: Sascha Silbe <[email-masked]>
Date: Fri, 04 Mar 2011 13:16:41 +0100

Excerpts from William Morgan's message of Wed Jan 26 16:18:59 +0100 2011:

> push access.

I've finally created a gitorious account. I don't quite like the wording
of the ToS [1] concerning licenses (the way I read it Gitorious AS is
allowed to redistribute my code using a proprietary license), but
then the sup repository with all my submitted patches already is hosted
by them...

> Then you can bypass the list mailing list for patches

I'm happy to push my patches, but I'd still prefer to get at least one
Reviewed-By to make sure my changes are kosher.

> master when prepping for a release.

Noted.

Sascha

[1] http://en.gitorious.org/tos/
-- 
http://sascha.silbe.org/
http://www.infra-silbe.de/
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Sascha Silbe <[email-masked]>
Date: Fri, 04 Mar 2011 13:19:03 +0100

Excerpts from Sascha Silbe's message of Fri Mar 04 13:16:41 +0100 2011:

> I've finally created a gitorious account.

Sascha

---

From: Wael Nasreddine <[email-masked]>
Date: Tue, 25 Jan 2011 18:04:55 +0100

Hello,

I'm just forwarding the message because it bounced coz I wasn't a member

Regards,
Wael Nasreddine

-- 
Wael Nasreddine
Sent from my iPhone

Begin forwarded message:

*From:* "Wael M. Nasreddine" <[email-masked]>
*Date:* January 25, 2011 15:19:10 GMT+01:00
*To:* William Morgan <[email-masked]>
*Cc:* sup-devel <[email-masked]>, [email-masked]
*Subject:* *Re: [sup-talk] call for new maintainers*

Hello,

Regards,
Wael Nasreddine

---

From: Tero Tilus <[email-masked]>
Date: Thu, 27 Jan 2011 09:31:38 +0200

William Morgan, 2011-01-26 17:18:
> Gitorious usernames

-- 
Tero Tilus ## 050 3635 235 ## http://tero.tilus.net/
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel