Subject: [sup-devel] [PATCH] call index.load in sup-add

From: Rich Lane <[email-masked]>
Date: Wed, 6 Jan 2010 19:34:18 -0800

If it's going to call index.save, it needs to load it first.
---
 bin/sup-add |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)

diff --git a/bin/sup-add b/bin/sup-add
index c53378d..a7a3752 100755
--- a/bin/sup-add
+++ b/bin/sup-add
@@ -86,6 +86,7 @@ end
 $terminal.wrap_at = :auto
 Redwood::start
 index = Redwood::Index.init
+index.load
 
 index.lock_interactively or exit
 
-- 
1.6.5.2

_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: William Morgan <[email-masked]>
Date: Thu, 14 Jan 2010 08:55:00 -0500

> If it's going to call index.save, it needs to load it first.

Applied to master, thanks!
-- 
William <[email-masked]>
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel