Subject: [sup-devel] [issue106] Crash with exception :undefined method 'ord'

From: anonymous <[email-masked]>
Date: Mon, 31 May 2010 11:48:29 +0000

New submission from anonymous:

Crash.
Attached exception log.

----------
files: exception-log.txt
messages: 241
nosy: anonymous
priority: bug
ruby_version: ruby 1.8.6
status: unread
sup_version: 0.10
title: Crash with exception :undefined method 'ord'

_________________________________________
Sup issue tracker <[email-masked]>
<http://masanjin.net/sup-bugs/issue106>
_________________________________________

_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Ben Walton <[email-masked]>
Date: Mon, 31 May 2010 16:48:37 -0400

Excerpts from anonymous's message of Mon May 31 07:48:29 -0400 2010:

> --- NoMethodError from thread: main
> undefined method `ord' for 121:Fixnum
> /usr/lib/ruby/gems/1.8/gems/sup-0.10/lib/sup/buffer.rb:648:in `ask_yes_or_no'
> /usr/lib/ruby/gems/1.8/gems/sup-0.10/bin/sup:282
> /usr/bin/sup:19:in `load'
> /usr/bin/sup:19

You're running a pretty old sup.  Try updating.  There was a bug fixed
related to this method some time ago.

HTH.
-Ben
-- 
Ben Walton
Systems Programmer - CHASS
University of Toronto
C:416.407.5610 | W:416.978.4302