Subject: Re: [sup-devel] [Turnsole] Experimental GPG signature verification

From: Nicolas Pouillard <[email-masked]>
Date: Wed, 14 Mar 2012 14:38:43 +0100

Excerpts from Michael Stapelberg's message of 2012-03-14 14:31:04 +0100:
> Hi Nicolas,
> 
> Excerpts from Nicolas Pouillard's message of 2012-03-14 14:13:46 +0100:
> > Is there some missing file for getting CryptoManager? I get this:
> > 
> > .../lib/turnsole/modes/edit-message-mode.rb:106:in `initialize':
> >   uninitialized constant Turnsole::EditMessageMode::CryptoManager (NameError)
> No, this code is just not yet fixed for turnsole.

So there is no way to compose any message when merging your branch?
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Michael Stapelberg <[email-masked]>
Date: Mon, 12 Mar 2012 19:28:44 +0100

Hi,

At https://github.com/mstap/turnsole/commits/gpg-signed, you can find an
experimental branch which implements GPG signature verification. This should
work for PGP/MIME multipart/mixed, multipart/signed and PGP/INLINE. You also
need the changes of https://github.com/wmorgan/heliotrope/pull/42 in your
heliotrope for this to work.

GPG decryption is not working at all yet. Also, depending on your messages, you
might need to patch RMail (see my previous mail):

lib/rmail/parser/multipart.rb:211
  #s = PushbackReader.maybe_contains_re("--" + boundary)
  s = Regexp.quote("--" + boundary)

If you notice any problems, please report them.

Best regards,
Michael

PS: I’m not quite sure how to make Heliotrope pick up the "signed" label for
messages which are already indexed. The code now recognizes more signed
variants. Ideas?
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Michael Stapelberg <[email-masked]>
Date: Wed, 14 Mar 2012 14:31:04 +0100

Hi Nicolas,

Best regards,
Michael

---

From: Michael Stapelberg <[email-masked]>
Date: Sun, 18 Mar 2012 23:45:52 +0100

Hi Nicolas,

Excerpts from Michael Stapelberg's message of 2012-03-14 14:55:55 +0100:
> That might be true. To be honest, I don’t compose messages in heliotrope yet,
> otherwise, I won’t have them in sup (my fallback). Yes, the situation sucks big
> time.
This is fixed now with commit https://github.com/mstap/turnsole/commit/2817026

Best regards,
Michael

---

From: Nicolas Pouillard <[email-masked]>
Date: Wed, 14 Mar 2012 14:13:46 +0100

Hi,

---

From: Michael Stapelberg <[email-masked]>
Date: Wed, 14 Mar 2012 14:55:55 +0100

Hi Nicolas,

Best regards,
Michael

---

From: Nicolas Pouillard <[email-masked]>
Date: Mon, 19 Mar 2012 08:53:47 +0100

> This is fixed now with commit https://github.com/mstap/turnsole/commit/2817026

Thanks!