Subject: Re: [sup-devel] now in next: fix-utf8, ferret-removal, and remote-source-deprecation

From: Michael Hamann <[email-masked]>
Date: Sun, 28 Feb 2010 22:58:25 +0100

Hi,

thanks for your work, it seems I am able to send messages with UTF-8 subjects,
recipients, ...  again, but after pulling from next I first had to do the
following fixes in order to get sup working again (I don't know if there are
more, these are just the two ones that made sup unusable):

diff --git a/lib/sup/index.rb b/lib/sup/index.rb
index 548daf0..79bd1af 100644
--- a/lib/sup/index.rb
+++ b/lib/sup/index.rb
@@ -216,10 +216,10 @@ EOS
 
   ## Given an array of email addresses, return an array of Person objects that
   ## have sent mail to or received mail from any of the given addresses.
-  def load_contacts email_addresses, h={}
+  def load_contacts email_addresses, opts={}
     contacts = Set.new
     num = opts[:num] || 20
-    each_id_by_date :participants => emails do |id,b|
+    each_id_by_date :participants => email_addresses do |id,b|
       break if contacts.size >= num
       m = b.call
       ([m.from]+m.to+m.cc+m.bcc).compact.each { |p| contacts << [p.name, p.email] }
@@ -739,14 +739,14 @@ class Xapian::Document
 
   def index_text text, prefix, weight=1
     term_generator = Xapian::TermGenerator.new
-    term_generator.stemmer = Xapian::Stem.new(Redwood::XapianIndex::STEM_LANGUAGE)
+    term_generator.stemmer = Xapian::Stem.new(Redwood::Index::STEM_LANGUAGE)
     term_generator.document = self
     term_generator.index_text text, weight, prefix
   end
 
   alias old_add_term add_term
   def add_term term
-    if term.length <= Redwood::XapianIndex::MAX_TERM_LENGTH
+    if term.length <= Redwood::Index::MAX_TERM_LENGTH
       old_add_term term, 0
     else
       warn "dropping excessively long term #{term}"

Greetings
Michael
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Sun, 28 Feb 2010 18:36:26 -0500

Thanks, applied to ferret-removal and merged to next.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Rich Lane <[email-masked]>
Date: Sun, 28 Feb 2010 16:20:00 -0500

I fixed a couple of bugs related to sending utf8 mail. If you've been
having problems with that please try latest next.

Ferret is gone. If you've ignored the deprecation warning until now
you'll need to run sup-convert-ferret-index before upgrading Sup.

I've removed the code in sup-config and sup-add for adding imap and
mbox+ssh sources. I also added a deprecation warning on sup startup.
These sources will be removed from master immediately following the
release of 0.11, so please switch to rsync/offlineimap/fetchmail/etc
before then.

If no one reports problems with these branches I'll merge them to master
before releasing 0.11.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel