Subject: [sup-devel] [PATCH] [mq]: mbox-path-fix

From: Adam Lloyd <[email-masked]>
Date: Sat, 09 Oct 2010 16:48:11 -0400

diff --git a/lib/sup/mbox.rb b/lib/sup/mbox.rb
--- a/lib/sup/mbox.rb
+++ b/lib/sup/mbox.rb
@@ -90,8 +90,8 @@
   end
 
   def store_message date, from_email, &block
-    need_blank = File.exists?(@filename) && !File.zero?(@filename)
-    File.open(@filename, "ab") do |f|
+    need_blank = File.exists?(@path) && !File.zero?(@path)
+    File.open(@path, "ab") do |f|
       f.puts if need_blank
       f.puts "From #{from_email} #{date.asctime}"
       yield f
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Adam Lloyd <[email-masked]>
Date: Sat, 9 Oct 2010 16:54:07 -0400

Argh, /me is quite embarrassed.

Please ignore this; I'll resend my patch properly.  Apologies for the noise!

-Adam