Subject: Re: [sup-devel] [PATCH] Bugfix: Charset conversion needs to take place *after* verifying inline GPG signatures

From: Rich Lane <[email-masked]>
Date: Fri, 04 Jun 2010 22:55:08 -0400

Applied to master.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Michael Stapelberg <[email-masked]>
Date: Fri, 04 Jun 2010 11:59:53 +0200

Hi,

still fixing some inline GPG problems ;-). This one is a little subtle: If the
message arrives in a different encoding than UTF-8 (shame on the sender), the
verification will fail because sup modifies the message by converting it to
UTF-8. The attached patch fixes this.

Best regards,
Michael