Subject: Re: [sup-devel] [PATCH] Correctly pad date strings, as they might contain utf-8 characters

From: Rich Lane <[email-masked]>
Date: Thu, 11 Mar 2010 23:45:06 -0500

Excerpts from Michael Stapelberg's message of 2010-03-09 12:04:27 -0500:
> Hi,
> 
> attached you find a patch for this problem. Quote of the commit message:
> 
>   sprintf is not utf8-aware and thus the output gets a wrong padding
>   (correct in terms of bytes, not correct in terms of visible characters).
>   You can notice this using a german locale (de_DE) and viewing mails
>   from march (abbreviated "Mär" in german).
> 
> Best regards,
> Michael

Thanks, applied directly to master.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Michael Stapelberg <[email-masked]>
Date: Tue, 09 Mar 2010 18:04:27 +0100

Hi,

Best regards,
Michael