Subject: [sup-devel] Sup 0.12 released

From: Rich Lane <[email-masked]>
Date: Sat, 15 Jan 2011 02:07:28 -0500

I'm pleased to announce the release of Sup 0.12.

Sup is a console-based email client for people with a lot of email.
It supports tagging, very fast full-text search, automatic contact-
list management, and more. If you're the type of person who treats
email as an extension of your long-term memory, Sup is for you.

Get it: gem install sup
Learn it: http://sup.rubyforge.org
Love it: [email-masked]

Release notes:

Deprecated remote sources have been removed.

Maildir support has been improved to gracefully handle messages that
move or disappear. The "out of sync" errors should no longer occur.

Inline GPG is now supported.

Changelog for 0.12:

* Remove deprecated IMAP, IMAPS, and mbox+ssh sources
* Inline GPG support
* Robust maildir support
* sup-dump compatibility between Sup versions
* New hook: sendmail
* Better Ruby 1.9/UTF8 support
* As always, many bugfixes and tweaks.
_______________________________________________
Sup-devel mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-devel

---

From: Shadowfirebird <[email-masked]>
Date: Mon, 17 Jan 2011 10:44:42 +0000

That's nice.

Can I make a  criticism?   Perhaps there should have been a warning that
upgrading is not just a matter of running "gem upgrade sup" because there
are engine changes, with a link to the detailed description on the web of
how to upgrade?

And perhaps you should put a detailed descrption on the web of how to
upgrade?

"This Sup version expects a v4 index, but you have an existing v2 index.
Please run sup-dump to save your labels, move /home/fred/.sup/xapian out of
the way, and run sup-sync --restore."

Perhaps it really is as simple as this, but this is my "live" data we are
talking about here.   A little hand-holding would not have gone amis.

On Sat, Jan 15, 2011 at 7:07 AM, Rich Lane <[email-masked]> wrote:

> sup-talk mailing list
> [email-masked]
> http://rubyforge.org/mailman/listinfo/sup-talk
>

-- 
What a tangled web we weave / Go 'round with circumstance / Someone show me
how to tell / The dancer from the dance...
_______________________________________________
sup-talk mailing list
[email-masked]
http://rubyforge.org/mailman/listinfo/sup-talk